ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

How to render H.264 files to MP4 not M4V?

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Ari Hwang
How to render H.264 files to MP4 not M4V?
on Oct 3, 2010 at 9:32:16 pm

I made a small animated signature and rendered it out perfectly fine with the settings H.264 to MP4.

But now everytime I render the files it changes the extension to M4V and I can't play those types of files and it won't work with my editing software either. How do I change it back?


Return to posts index

Conrad Olson
Re: How to render H.264 files to MP4 not M4V?
on Oct 4, 2010 at 3:11:04 pm

Can't you just change the extension name once it has rendered?

conradolson.com


Return to posts index

Dave LaRonde
Re: How to render H.264 files to MP4 not M4V?
on Oct 4, 2010 at 3:19:44 pm

[Ari Hwang] "I made a small animated signature and rendered it out perfectly fine with the settings H.264 to MP4."

If it looks all right to you that's great. But I wouldn't do what you did, and here's why:


Dave's Stock Answer #3:

Don't use AE to compress files for final delivery. The various compressors are there only to make quick 'n dirty files showing a project's progress to producers, clients, the kids, etc. AE is incapable of doing multipass encoding, a crucial feature that greatly improves the image quality of H.264 and MPEG-type files in particular.

Render a high-quality file from AE, and use a different application to do the compression. Popular ones are Adobe Media Encoder, Sorenson Squeeze and Apple's Compressor, which comes bundled with Final Cut Suite. Even compressing in Quicktime Pro is better than compressing in AE.

Making good-looking compressed files is almost as much an art as it is a science. It is NOT straightforward at all. I recommend asking a few questions at the COW's Compression Techniques forum.

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index


Kevin Camp
Re: How to render H.264 files to MP4 not M4V?
on Oct 4, 2010 at 4:36:16 pm

yep... and i would think your nle would do the conversion to the type of format and compression that it wants, so you may want to try rendering from ae as lossless animation, or if it doesn't have an alpha channel, perhaps quicktime photo-jpeg at around 95% quality, then import that into your nle.

if you nle does not import quicktime files, then try a compression app to compress either of those files to .mp4 with h.264 compression. adobe's media encoder should do this, or you could try mpegstream clip. just import your quicktime and choose file>export to mpeg4 and set the settings accordingly... in particular i'd enable multipass, b-frames, manually set the frame rate and leave the file unscaled. that pretty much leaves quality, limit data rate and audio compression for you to set to match your nle's settings.

Kevin Camp
Senior Designer
KCPQ, KMYQ & KRCW


Return to posts index

scott novasic
Re: How to render H.264 files to MP4 not M4V?
on Oct 4, 2010 at 10:33:32 pm

quicktime pro is a fast and decent way to compress files. The other advice is solid as well.

Scott

SuperNova
Animation & Visual Effects
Scott Novasic
Los Angeles Ca
web:http://web.mac.com/finaleffects


Return to posts index

Gary Jennings
Re: How to render H.264 files to MP4 not M4V?
on Jul 23, 2013 at 6:11:06 pm

Dave people want to render h 2.64 because it doesn't take must time to render and it doesn't take up much space. Every post I see you in about h 2.64 is the same cut and paste response from you. QUIT IT! Answer the question provided or STFU. If someone wants to render H264 then let them render it.


Return to posts index


Adelbert Weidler
Re: How to render H.264 files to MP4 not M4V?
on Apr 5, 2013 at 10:28:18 am

Same Problem here.
Adobe Media Encoder CS6 produces m4vs when I choose h.264 as format.
Settings are all alright. Even the filename-preview has the mp4 ending as it should! But in the end a m4v is created.
Is this a bug, a feature or do I miss some hidden setting?


Return to posts index

Evan Mueller
Re: How to render H.264 files to MP4 not M4V?
on May 16, 2013 at 7:06:17 pm

Exporting in H.264 with the audio disabled will continually produce an .m4v, despite the output file being listed as .mp4 in Adobe Media Encoder CS6.
Workaround is to mute audio in the project and export with audio or use another encoder (MPEG Streamclip) to create an .mp4 from a master.

http://www.evanmueller.com


Return to posts index

Gary Jennings
Re: How to render H.264 files to MP4 not M4V?
on Jul 24, 2013 at 4:26:57 pm

I found the answer, Don't listen to dave: http://forums.adobe.com/message/5532113


Return to posts index


Rockstar Bruski
Re: How to render H.264 files to MP4 not M4V?
on Apr 3, 2015 at 5:22:58 am

FWIW it's 2015-04-02 and I'm running into this same exact problem with Adobe Premiere CS6 fully patched to the latest version as of today's date.

a week ago I was able to render to mp4's just fine even with export audio unchecked. However, today with export audio unchecked it will only render m4v files.

I've researched for an hour reading all the work arounds and yes checking export audio allows it to render Mp4s again. And yes all my multiplexer output in CS6 is set correctly.

So, I'm guessing the sometime last week some kind of update happened to my CS6 and now I have to export audio to get it to render mp4s. I find this crazy that this bug has gone on for years according to people's posts way back to 2013 or earlier. This reminds me of the media not found bug that never got fixed and every now and then I have to do the cumbersome workaround for that bug. Ugghh! This software is way too expensive to allow these types of bugs to go on unfixed for this long! vent vent vent. :(


Return to posts index

Jorge Del Campo Andrade
Re: How to render H.264 files to MP4 not M4V?
on Aug 18, 2015 at 3:26:14 pm

Hi Ari. Remember if you render only video but not the audio, the h.264 resulting format always be m4v. The problem seems to be the check-off audio render. Have you're rendering video without audio?. Taste rendering audio and video (click on both check-boxs) and problem solved!
Salutes,


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]