ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Particular grid emitter stair-stepping

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Matt SlocumParticular grid emitter stair-stepping
by on Sep 28, 2010 at 3:03:59 pm

I'm trying to draw lines to swoop around (maybe 10 lines). I want them to be evenly spaced and kinda look like a ribbon. I changed the emitter to grid and the grid emitter particles in x,y,z to 1,10,1 and the type to Traverse. It seems to do what I want except that on fast motion it gives drastic stair-stepping. I tried changing the Position Subframe setting, but that isn't working.

I am new to particluar, in fact, I'm using the trial to see if it can do what I want before I buy it. Is this a trial limitation or am I doing something wrong?

Thanks,
Matt

AE 10.0.0.458
Particluar 2.1.0


Return to posts index

Dave LaRondeRe: Particular grid emitter stair-stepping
by on Sep 28, 2010 at 3:36:27 pm

Would something like this work?
http://library.creativecow.net/articles/kramer_andrew/nano.php

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

Matt SlocumRe: Particular grid emitter stair-stepping
by on Sep 28, 2010 at 3:46:06 pm

Maybe, I was playing around with that a little. I might end up making a custom particle, but I wanted more controls of animating line proximity without scaling the custom particle. It seems like the grid emitter is exactly what I want, but it seems broken, or I'm doing something wrong. That is why I was also wondering if it had to do with my trial license.


Return to posts index


Dave LaRondeRe: Particular grid emitter stair-stepping
by on Sep 28, 2010 at 4:09:55 pm

It probably has more to do with speed: your particles aren't packed closely enough to make a continuous-looking line.

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

Matt SlocumRe: Particular grid emitter stair-stepping
by on Sep 28, 2010 at 4:22:52 pm

I tried increasing the Particles/sec up really high, but that doesn't help. Increasing the frames per second on the comp helps some, but I guess I'm going to have to do the animation over a lot more frames and then speed it up to make the lines smooth. I thought I read that they fixed this with Particular 2?


Return to posts index

John CuevasRe: Particular grid emitter stair-stepping
by on Sep 28, 2010 at 4:46:49 pm

Can you post a picture? I'm not entirely sure exactly what you are seeing.

Johnny Cuevas, Editor
http://www.thinkck.com


Return to posts index


Matt SlocumRe: Particular grid emitter stair-stepping
by on Sep 28, 2010 at 4:53:58 pm

The XYZ Positions, XYZ Rotation and XYZ Size are linked to a null that is animating over 20 frames. It is moving about 1000 pixels and rotating 180 degrees.


Return to posts index

Matt SlocumRe: Particular grid emitter stair-stepping
by on Sep 28, 2010 at 4:55:04 pm



Return to posts index


John CuevasRe: Particular grid emitter stair-stepping
by on Sep 29, 2010 at 12:27:54 am

Took me a bit to get back to this, been a busy day. So I messed around with this and it's basically a math problem. You have the null rotating at 9 degrees every frame with a large velocity. Even from your picture, you can see that over 20 frames you get 20 lines, each 9 degrees apart. To get a smooth line you would have to adjust your frame rate 9 times faster to get a 1 degree move, or 180 frames per second but AE only goes up to 99 frames per second.

To get the animation you want, you need to move your keyframes to 6 seconds(9 times the length it currently is). Precomp the entire thing and time remap.

Johnny Cuevas, Editor
http://www.thinkck.com


Return to posts index


Matt SlocumRe: Particular grid emitter stair-stepping
by on Sep 29, 2010 at 1:20:58 am

Yeah John, I think you're right. I was thinking that would be it, but I was hoping it would be a setting. I thought they claimed they fixed this with the new Position Subframe, but I guess it doesn't work with grids.

Thanks.


Return to posts index


John CuevasRe: Particular grid emitter stair-stepping
by on Sep 29, 2010 at 10:59:30 am

Poking around, I found this thread from Norby: http://www.trapcode.com/forum/post/1031327

Basically, there is no subframe accuracy for rotation.

There is another work around, if you really need this to happen over 20 frames. Use lights. Create 10 lights in a straight vertical line. Parent them to your 3D null, change the emitter from grid to lights(s). Motion does have subframe accurracy. I did a quick test using the same parameters as before, (velocity, rotation) over 20 frames, but only needed 1500 particles to make the lines. Hope that helps you out.



Johnny Cuevas, Editor
http://www.thinkck.com


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]