ADOBE AFTER EFFECTS: Forum Expressions Tutorials Podcasts Creative Cloud

Precomped 3d layers loose material and light controls

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
mike harringtonPrecomped 3d layers loose material and light controls
by on Sep 6, 2010 at 12:25:28 am

I am doing a complex 3d comp...
I am making some steel beams that go along a wall...20 or so
So there is a layer for each side of the beam in all about 60 layers.
The layers are positioned in a H shape with 20 shapes

Naturally the thing to do would be to precomp all of them but I am running into a problem. When I click collapse transforms I lose all material controls and the beams no longer cast shadows. If I uncheck collapse transforms the materials come back but my beams become flat planes in 3d space but they no longer have the H shape.

The only solution I have found is not to precomp....but that of course will make a mess.

Any insight into collapse transforms and materials in a 3d precomp would be appreciated...


Return to posts index

Tudor "Ted" JelescuRe: Precomped 3d layers loose material and light controls
by on Sep 6, 2010 at 11:09:50 am

It seems that in AE a precomp with 3D inside and the collapse transformation switch on keeps the 3d but not the cast shadows and other material options- it also looses the motion blur ability.
The workaround- for a cleaner comp- create your 3d structure in a separate comp, enable material properties, parent all to a Null, copy the whole thing and paste in your master comp. Enable "Shy" switch on all layers but the Null and turn hide shy layers on. You get one layer that controls all the 3d structure, all material properties and ability to cast shadows plus motion blur- hope it helps.

Tudor "Ted" Jelescu
Senior Compositor/VFX Artist
Bucharest, Romania

Return to posts index

Cassius MarquesRe: Precomped 3d layers loose material and light controls
by on Sep 6, 2010 at 5:37:32 pm

Well, things can get tricky with precomps...

Make sure:
*Your precomp has no effects applied, turning them off wont have to delete them.
*each layer inside the precomp is set to cast/receive lights/shadows
*Photoshop layer styles are not used (right click all layers in the precomp go to layer styles -> remove all) I've seen this messing things up.
*In the main comp, watch for 2d layers between your precomp and other layers (e.g. your background) 2D layers, will break the 3D "stack".

If you had all that done before, then all I can think of is to duplicate every camera and lights into the precomp (and don't collapse it) sucks but on some occasions I can't seem to avoid it.

hope this helps, good luck.

Return to posts index

mike harringtonRe: Precomped 3d layers loose material and light controls
by on Sep 7, 2010 at 4:54:45 am

Thanks for the advice...
Right now I am making use of the shy button and organizing my comp accordingly....

I may try it again making sure there are no 2d layers inbetween the 3d stack...I had already set each layer in the precomp to recieve lights....either way I should get it to work


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 All Rights Reserved