ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Lights turning every 3D layer black

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Steve EdwardsLights turning every 3D layer black
by on Aug 10, 2010 at 4:58:39 am

Hi,

I'm a rather seasoned After Effects user so this question might seem simple but it's not a simple answer.

I have some 3D layers setup in AE (ALL not colored balck and ALL have the appropriate "accept lights" "cast shadows" etc switched on), and basically when I add any light into the scene they all suddenly turn completely black. This even happens with ambient lights which don't even have a position in space.

Has anybody had this problem before?? I can't find anything about it on the web. It started happening in the middle of a project and I thought perhaps it has something to do with 3D rendering but everything seems normal and I haven't changed any settings recently.

Any help would be appreciated.


Return to posts index

Walter SoykaRe: Lights turning every 3D layer black
by on Aug 10, 2010 at 10:05:08 am

Have you accidentally clicked the Draft 3D mode button at the top of the timeline panel?

Walter Soyka
Principal & Designer at Keen Live
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
RenderBreak Blog - What I'm thinking when my workstation's thinking
Creative Cow Forum Host: Live & Stage Events


Return to posts index

Adriano MoraesRe: Lights turning every 3D layer black
by on Aug 10, 2010 at 12:34:42 pm

Since we are exploring accidents area....are the lights by any chance set to -100% on the intensity value?

Just a thought.


Cheers.


Return to posts index


Steve EdwardsRe: Lights turning every 3D layer black
by on Aug 11, 2010 at 12:33:01 am

To both Adriano and Walter I'm afraid the answer is no (but you guys both have cool names!)

My comp is not set to draft mode and the lights are set to a normal 100% intensity. It's a really strange problem and it just got stranger...

It started happening in the middle of a project and I've found that if I add a new light via a menu it makes everything black no matter where I position it or what type of light it is. However, if I copy a light from a previous composition (where the lights are working) to the current problem composition, they will work perfectly normally.

So...i basically have no idea what's going on, it's really weird. I explained it to a fellow co-worker/after effects user (in real life) and she couldn't understand it either. She did nicely title the problem as "Devil lights" though. hehe

I thought perhaps it's something to do with rendering but then I don't understand why a copied light would suddenly make it work.

Anyway at least i've found a workaround for now.


Return to posts index

Daniel HamiltonRe: Lights turning every 3D layer black
by on Aug 8, 2011 at 2:33:36 pm

The same just started happening to me this morning. Nothing I try will make lights work again. Very frustrating.


Return to posts index

Scott O'BanionRe: Lights turning every 3D layer black
by on Apr 12, 2013 at 2:30:57 pm

I see this is an older post but I am having the same issue. Is there any chance you have resolved this issue and if so can you please tell me how?

Thank you


Return to posts index


Jason FeaserRe: Lights turning every 3D layer black
by on Apr 18, 2013 at 9:30:19 am

Same here. Text layers, colored solid layers, all black. The lights cast no shadows on anything either. Accept shadows, etc are all enabled. Draft 3D is not enabled either. Very strange. Does anyone have any clue why this would be happening ? I am using CS6 and in ray trace mode.

This is just like a party except there isn't any music. And there aren't any woman. And we aren't having any fun.


Return to posts index

Walter SoykaRe: Lights turning every 3D layer black
by on Apr 18, 2013 at 2:21:13 pm

Can anybody post a sample AEP project here showing the problem?

Walter Soyka
Principal & Designer at Keen Live
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
RenderBreak Blog - What I'm thinking when my workstation's thinking
Creative Cow Forum Host: Live & Stage Events


Return to posts index

Dok KimRe: Lights turning every 3D layer black
by on Apr 22, 2013 at 9:22:47 pm

I just had the same problem and I figured it out.
When I added a light the view was at "Back" and not "Active Camera" (I don't know why)...
The view as Active Camera fixed my issue.


Return to posts index


Jared PetersenRe: Lights turning every 3D layer black
by on Apr 16, 2014 at 1:46:10 pm

I know this was a long time ago, but for anybody looking for an answer, I was having the same problem, and just went into Material Options and then turned Accepts Shadows to Only. That seems to keep my white layers white after turning them all black.


Return to posts index

Alex KlimovRe: Lights turning every 3D layer black
by on Oct 15, 2014 at 1:48:02 pm

Sorry for necroposting again, but no, it just turns it to white. Having issue, anyone up with solution? Tried all kind of lights.


Return to posts index

Walter SoykaRe: Lights turning every 3D layer black
by on Oct 15, 2014 at 2:24:41 pm

If you do not want lights to affect a 3D layer, set its "Accept lights" property to off. This will prevent it from being shaded by the light. If you do want it to be affect by lights, you'll have to leave that property on and point a light at it.

Walter Soyka
Designer & Mad Scientist at Keen Live [link]
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
@keenlive [twitter]   |   RenderBreak [blog]   |   Profile [LinkedIn]


Return to posts index


Donald DaedalusRe: Lights turning every 3D layer black
by on Jun 8, 2015 at 2:53:36 pm

If you export and certain elements of a 3D comp come out black, it may be that pre-comps have the Draft 3D button on. These are like negatives in math; double negatives look like a positive when you are working but when you go to render or export, the element comes out black.

Additionally, try making the lights of pre-comps or nested comps adjustment layers within the nested comp.

-D


Return to posts index

Richard MullerRe: Lights turning every 3D layer black
by on Apr 12, 2016 at 6:28:33 pm

I know this is really old, but I was having the same issue, and I changed the "falloff" option under "light options" from "smooth" to "none."

I'm sure there are different reasons why this could be a problem. I know another problem I've had in the past is that the "point of interest" for the light started off behind the objects, so it wasn't casting light on them.

Hope either of these solutions help!


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]