ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Rendering settings

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Esmer BombaRendering settings
by on Jul 6, 2010 at 3:01:30 pm

Hello people,

Let me start my showing you the screenprints that I've made for making it easier to understand.



The image on the left is a screenprint from my After Effects project window. The image on the right is a screenprint of the result after rendering. As you can see the result looks grainy and there is a bit of discoloration.

I'm wondering if anyone can help me out with using the right settings. The output has to be FLV because I'm importing the animation into Flash. The image below is a screenprint from Adobe Media Encoder. You can see here the settings that I've been using.



I hope I gave you enough information to solve my problem. I'm using CS5 on Windows 7.

Cheers, Esmer


Return to posts index

Dave LaRondeRe: Rendering settings
by on Jul 6, 2010 at 3:49:51 pm

What are you using to view the rendered file? Another viewer may have a different default gamma setting, which could explain the difference you see. Your render may be perfectly fine.

I'd try using it as intended, and see what happens.

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

Esmer BombaRe: Rendering settings
by on Jul 6, 2010 at 4:26:54 pm

I've imported the FLV render into Flash, previewed it, and took screenprints.

Is it possible that maybe a setting in my After Effects project file causes this problem? Because when you look closer to the preview window of Adobe Media Encoder, it already shows a bit of discoloration. This is before encoding it to FLV.

I'll do some tests with other file formats and post some results later on.


Return to posts index


Esmer BombaRe: Rendering settings
by on Jul 6, 2010 at 5:00:14 pm

I see why the discoloration took place.

In my After Effects project window I work with a transparent background (chessboard pattern). If I turn this off, a black background appears and the discoloration shows up.

Anyway, I can 'fix' this by ignoring the transparency and render the project including my custom background picture. But when I do this, the bad quality that a mentioned earlier becomes really noticeable. See the images below. The image on the left is a screenprint from my After Effects project window. The image on the right is a screenprint of the result after rendering.



The only thing that has to be fixed is the grainy quality that I'm getting after I render with the settings that I posted earlier. How can I fix this? With different settings? Or should I switch over to a different encoding program?


Return to posts index

Dave LaRondeRe: Rendering settings
by on Jul 6, 2010 at 6:27:18 pm

I see you limited the file's bit rate to 1 megabyte/second. I normally use video recorded at 50 and 100 MB/sec.

Do you see a difference in values? As an engineer at my TV station told me a long time ago, "When you compress a file, you're throwing away information. You have to ask yourself how much information you want to throw away."

At such a low bit rate, you can't expect perfection, you know.

Furthermore, you haven't told us how you're using this file, just that you're compressing the file. There are different codecs for different uses, and there may be a better one for your purposes.

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

Esmer BombaRe: Rendering settings
by on Jul 6, 2010 at 9:35:27 pm

The bitrate is set to 10 kbps because I can't increase the amount further.

I want to embed the animation into my Flash project, so it has to be a FLV file. I actually tried to render it as a F4V file. This gave me a pretty good result. But unfortunately Flash won't allow me to embed this filetype. It doesn't allow me to embed any filetype but FLV.

So I think I'm stuck here. I have to use FLV, but Adobe Media Encoder doesn't give me the result I want. I prefer uncompressed quality, but I'm afraid that this will give me large files.


Return to posts index


Dave LaRondeRe: Rendering settings
by on Jul 6, 2010 at 9:51:06 pm

I think it's possible to trick Flash into using H.264-encoded video if you don't need an alpha channel. You change the file extension to .flv.

But don't use AE to make the H.264. Render high-quality in AE, and use Adobe Media Encoder to make the H.264.

I've never done it personally, but I think I recall someone using this trick.

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]