ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

AE Z depth camera move creating unwanted transparency

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Brett UnderhillAE Z depth camera move creating unwanted transparency
by on Jun 23, 2010 at 3:22:45 am

So have some imported AI objects on z depth planes and when I do a z depth camera move towards them or out (like a tracking in or out shot) I get unwanted transparency on some of the objects. Any idea what could be causing this?


Return to posts index

Kevin CampRe: AE Z depth camera move creating unwanted transparency
by on Jun 23, 2010 at 11:49:37 am

if you are seeing this in the ram preview, try going to preferences>previews and disable opengl for previews (just uncheck the 'use opengl' check box).

Kevin Camp
Senior Designer
KCPQ, KMYQ & KRCW


Return to posts index

Brett UnderhillRe: AE Z depth camera move creating unwanted transparency
by on Jun 23, 2010 at 12:11:27 pm

Thanks Kevin,

It's not in the RAM preview at all, the transparency only appears once the movie is made. I should mention that motion blur is also on.


Return to posts index


Kevin CampRe: AE Z depth camera move creating unwanted transparency
by on Jun 23, 2010 at 4:25:18 pm

is there any commonality between the layers that are going transparent.

are they using a common effect, on the same z plane, possibly the only layers with motion blur on...

opengl asside, i can't think of a reason why ae would randomly effect transparency of some layers...

you mentioned motion blur is on, have you tried a test render without motion blur? you can override a motion blur render in the render settings from the render queue, that's easier than unchecking mo-blur for all your layers. just remember to re-enable mo-blur in the render settings later on.

Kevin Camp
Senior Designer
KCPQ, KMYQ & KRCW


Return to posts index

Brett UnderhillRe: AE Z depth camera move creating unwanted transparency
by on Jun 23, 2010 at 9:53:27 pm

The only commonality is the Z depth and motion blur is active and they become about 75% transparent during a camera move. They aren't even moving, meanwhile, there are other layers that also have z depth active and they don't lose opacity. I copied the layers and made the copied layers active only during the camera move, without motion blur, and that seems to work. Doesn't make any sense for them to lose become transparent.

Thanks Kevin,

-Brett


Return to posts index

Jeff SchaapRe: AE Z depth camera move creating unwanted transparency
by on Aug 27, 2013 at 1:18:58 am

Same problem for me... 3 years later! My situation and the unwanted effect is exactly as you described. Ever solve it?

Jeff


Return to posts index


Brett UnderhillRe: AE Z depth camera move creating unwanted transparency
by on Aug 27, 2013 at 2:52:29 pm

Actually this problem still pops up for me every once in a while. For me, it was caused by the combination of a camera move + motion blur, and usually affects layers on the same plane in Z space. Try moving one of the layers forward just slightly in Z space.


Return to posts index

nick tallentsRe: AE Z depth camera move creating unwanted transparency
by on Oct 30, 2013 at 9:04:15 am

Thanks Brett - So glad you guys have posted on here, I too am having these issues, but was concerned it was a "why is this only happening to me' situation!

I have attached a screen grab (uuggghh its too early for christmas!).

All the bells are swinging left to right with a script driving the animation, but only when the camera pulls back in z-space does the transparency occur, and only in the render, not ram preview.

I did predict it could be due to all layers being on the same z-depth but i moved them forward by 4 pixels and did another render last night and its still there. My last and only hope is to remove motion blur and see if that helps.

Jeff how did you get on in the end?


"Life's a progress bar"


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]