ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

CS5 Render Settings Nightmare

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Nicholas Hauselman
CS5 Render Settings Nightmare
on Jun 11, 2010 at 6:21:32 pm

Could anyone take pity on me and help me configure my render settings so they don't shut down my system and allow me to work in Final Cut while it's rendering?
Here's what I got:
2 x 3 GHz Quad-Core Intel Xeon with 8 GB of RAM with a NVIDIA GeForce 8800 GT video card

When I render, it says it's only using 14% of the RAM, yet the whole system crawls to the point I can't even use Firefox while it's rendering - and it also seems pathetically slow when I'm just rendering 45 seconds of a comp with keylight as the only effect on one layer of the 8 - the other layers being tiny graphic jpegs at 72 dpi.

I've never been able to master the new settings on either CS4 or CS5 and I'm dying here...
THANKS


Return to posts index

Dave LaRonde
Re: CS5 Render Settings Nightmare
on Jun 11, 2010 at 7:35:24 pm

That 14% RAM utilization figure can be EXTREMELY deceptive. I wouldn't pay any attention to it.

First, you should understand that even though Adobe hyped the bejeebers out of Premiere's pairing with NVidia cards -- and it's very cool, I must admit -- it doesn't do one single, blessed thing for AE. Sorry.

Second, 8GB isn't a whole heck of a lot of memory in AE-Land. Heck, AE can use 4GB for each CORE in multiprocessing mode, and even more to handle the RAM-intensive chores of working with big images. On your machine, AE easily could use 32 GB... and more!

Third, FCP can use 4GB RAM all by itself, leaving only 4GB for AE on your machine. Not good.

So lessee, here You're rendering in AE, running FCP and trying to use Firefox? See any memory problems arising?

If I were you, I wouldn't try to use AE and FCP simultaneously until I got a whole boatload more memory.

And just so you know, I only have 8 gigs on my Mac Pro at work, and I don't even try to use multiprocessing.

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

Nicholas Hauselman
Re: CS5 Render Settings Nightmare
on Jun 11, 2010 at 7:54:37 pm

Thanks for depressing me even further! LOL
Well, I used to use CS4 and I could render out sequences in Final Cut while I was doing crazy 3D layered renders in AE with no problem. I can't believe 8 GB of RAM is not a lot - I'm not sure how much I can get in this box, but c'mon - that should be plenty to do both - although I guess you're saying it's not, but...sheesh

And firefox should use a teeny tiny amount of RAM...
Thanks...


Return to posts index


Dave LaRonde
Re: CS5 Render Settings Nightmare
on Jun 11, 2010 at 8:04:28 pm

[Nicholas Hauselman] "...I can't believe 8 GB of RAM is not a lot... I guess you're saying it's not, but...sheesh... "

AE is the Ultimate RAM Hog. No fooling.

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

Michael Szalapski
Re: CS5 Render Settings Nightmare
on Jun 11, 2010 at 7:50:54 pm

What other software is running? Anti-virus? What OS are you using? (I'm guessing some Mac version since you mention Final Cut)
What are your current render settings? What sort of hard drive are you rendering to? Are you using OpenGL in your render? What are your multiprocessing settings?

- The Great Szalam
(The 'Great' stands for 'Not So Great, in fact, Extremely Humble')

No trees were harmed in the creation of this message, but several thousand electrons were mildly inconvenienced.


Return to posts index

Nicholas Hauselman
Re: CS5 Render Settings Nightmare
on Jun 11, 2010 at 8:00:08 pm

I don't have anti-virus software - I'm running 10.6.3
I've got Snapz Pro running in the background, textEdit, that's about it for the background.

My render settings are as follows:
RAM reserved for other applications: 2.2 GB
RAM available for AE: 5.8 GB
Render Multiple Frames Simultaneously is checked
CPUs reserved for other apps: 2
RAM allocation per background CPU: .75 GB
Actual CPU's that will be used: 6

I'm not sure how these got set - I might've played with them when I installed CS5, but I think most of these were how it came...


Return to posts index


Darby Edelen
Re: CS5 Render Settings Nightmare
on Jun 12, 2010 at 1:21:58 am

[Nicholas Hauselman] "My render settings are as follows:
RAM reserved for other applications: 2.2 GB
RAM available for AE: 5.8 GB
Render Multiple Frames Simultaneously is checked
CPUs reserved for other apps: 2
RAM allocation per background CPU: .75 GB
Actual CPU's that will be used: 6"


Here are my recommended settings for your system:

RAM reserved for other applications: 4 GB
RAM available for AE: 4 GB
Render Multiple Frames Simultaneously is checked
CPUs reserved for other apps: 6
RAM allocation per background CPU: 1 GB
Actual CPU's that will be used: 2

Darby Edelen


Return to posts index

Kevin Camp
Re: CS5 Render Settings Nightmare
on Jun 11, 2010 at 8:27:30 pm

as michael states, knowing more about your comps and settings would help.

but a few things i would try:

-with only 8gb of ram, if you want to run other apps when ae is rendering, i would disable multiprocessing in ae.

-further, i would leave ram for other apps at around 4gb to make sure that fcp and the os have ram to work with.

-if you only have one drive or multiple drives on a single bus (like two internal drives on the internal bus), disable disk caching.

-as for keying slowness, the type of codec used for the media that you are keying can have a dramatic effect on how fast you can key. footage that is less compressed (like uncompressed or lossless animation) will usually key faster than more compressed footage (like png, avcintra), it just takes less processing power to decode each frame. and if you are using compressed footage that uses temporal/interframe compression (like mpeg2, hdv, h.264) then you're wasting even more processing time to decode each frame to key... switching from an interframe compression codec (like hdv) to an intraframe compression codec (lossless animation) will be like night and day when it comes to speed.

Kevin Camp
Senior Designer
KCPQ, KMYQ & KRCW


Return to posts index

Nicholas Hauselman
Re: CS5 Render Settings Nightmare
on Jun 11, 2010 at 11:39:33 pm

Thanks for the great answer. I'm a fan of KCRW, by the way...
I've started a video blog so all I'm doing is capturing video in Quicktime from my PD150 and bringing it into After Effects to key out the green screen. The codec QT uses for its recordings is DV/DVCPRO - NTSC 720x480 - so is there anything I should do to those files before bringing it into AE to speed up the render? I don't think I can change how Quicktime records its video...
As for render settings, I listed them above. I do have openGL enabled - but I thought that was strictly for RAM Previews, not rendering. Should I uncheck it?
As for the comps themselves - I just have a 1280x720 background tiff at 72 dpi, the quicktime file with green screen, using keylight, and a text layer or two on top of that. Seems like this should render in a snap - especially since the comps are no longer than one minute tops.
THANKS for any more help on this!


Return to posts index


Eric MacKay
Re: CS5 Render Settings Nightmare
on Sep 13, 2010 at 3:06:59 am

I suggest you disable multiprocessing. CS5 does this automatically. Playing with the settings is likely to just either over or under schedule your processor. Test this by rendering out a scene with it on and with it off again. See what happens to your render time.

Also, check out this script. It is free and will allow you to render in the background. This will make AE use only spare cpu cycles, leaving you to work in FCP with ease. It will of course slow your renders a bit depending on what you are doing.

http://aescripts.com/bg-renderer/

Also, do you have your cache enabled? Enable it and set the size to be equal to how much ram you have. This will speed up your renders.

As for OpenGl... nearly everyone turns this option off for rendering because it degrades video quality. But if you like using it in your preview window go for it, you might see some speed increases. I turn it off because it causes stability problems for me.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]