ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Rendering optimization?

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
malcolm DeSotoRendering optimization?
by on Apr 24, 2010 at 8:41:55 pm

Trying to render out a pretty effect intensive project. The last time I rendered this out, it took over 20 hours. There are a lot of 3D elements and complex effects. I have everything precompped that I can.

As of now, AE will render about one second and then say:

"After Effects: not enough memory to create memory for blurring"

I'm rendering out a quick time, animation codec set to medium (64).

I have multiprocessing on. In the 'secret' setting, I have AE purging every 30 frames.

I've been scanning through the manual to see if I can tweak anything else to make this work a little smoother.

It doesn't make sense to me being that I rendered this project out before. It took a long time, but it rendered. I just had to make a few client changes, none that should alter the rendering speed too dramatically.

Is there anything else I can do?

Thanks


Return to posts index

Walter SoykaRe: Rendering optimization?
by on Apr 24, 2010 at 9:21:16 pm

How much RAM do you have, and what are your multiprocessing settings?

Walter Soyka
Principal & Designer at Keen Live
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
RenderBreak Blog - What I'm thinking when my workstation's thinking
Creative Cow Forum Host: Live & Stage Events


Return to posts index

Todd KoprivaRe: Rendering optimization?
by on Apr 24, 2010 at 9:22:35 pm

> As of now, AE will render about one second and then say:
> "After Effects: not enough memory to create memory for blurring"
> I have multiprocessing on.


Only turn Render Multiple Frames Simultaneously multiprocessing on to speed up a render that is succeeding otherwise. If you're getting an error that says that you're running out of memory, the worst thing that you can do is turn on a feature that splits up your memory among several rendering processes.

> I have everything precompped that I can.


Do you mean that you have everything _prerendered_ that you can? Merely precomposing doesn't really help with rendering speed or memory problems. (Actually, it can do the opposite under some circumstances.) What you want to do is prerender those precomposed items.

You also didn't say anything about what versions of software (After Effects, OS) you're using, how much RAM, etc.

See this page for more information: "Improve performance".


---------------------------------------------------------------------------------------------------------
Todd Kopriva, Adobe Systems Incorporated
putting the 'T' back in 'RTFM' : After Effects Help on the Web
---------------------------------------------------------------------------------------------------------
If a page of After Effects Help answers your question, please consider rating it. If you have a tip, technique, or link to share---or if there is something that you'd like to see added or improved---please leave a comment.


Return to posts index


malcolm DeSotoRe: Rendering optimization?
by on Apr 27, 2010 at 5:09:48 pm

Windows XP
Dual 2.8
4GB RAM
After Effects 7

okay, I'll turn off multiprocessing.I'm trying to prerender the elements that I can, but it's a complex 3D project and some of the prerenders end up getting knocked out of 3D space or just not interacting with the rest of the comp correctly.

"The secret to creativity is knowing how to hide your sources." --Albert Einstein



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]