ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

8bit ram previews of 32bit project

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Martin Stacey8bit ram previews of 32bit project
by on Apr 21, 2010 at 9:28:20 am

Hi, i'm working on a project in 32bit linear. when i ram preview it, it displays in 8bit. weird thing is, if i ram preview it, and then press the space bar to just play it, it plays in 32bit.
any ideas why this is happening?


Return to posts index

Jon BaggeRe: 8bit ram previews of 32bit project
by on Apr 21, 2010 at 10:33:47 am

I'm pretty sure it's not possible to view in anything else than 8-bit. If you have very special hardware and an expensive monitor you can do 10-bit, but I think that's the limit.

16/32 bit refers to how after effects handle everything internally. At the end of rendering/previewing it turns it all into 8-bit before it goes to your monitor.

Therefore any colour in 32-bit above value 1.0 will be white on your screen no matter how high the value is. But of course you can use the higher values to achieve certain effects, and even use level/curves to bring it down if you wish.

This also applies to a linear workspace. You can achieve more subtle blending effects that way, but at the end of rendering I think AE will convert it into a gamma that you can view on your monitor. I could be wrong about how that works in preview though, my machine really isn't fast enough to do much 32bit work yet.





--------------
Jon Bagge
Editor - London, UK
Avid - FCP - After Effects


Return to posts index

Martin StaceyRe: 8bit ram previews of 32bit project
by on Apr 21, 2010 at 10:40:27 am

yeah, cool, i (kinda) understand that. but the weird thing is when it's not in ram preview i see it how i'd expect, i.e. nice gradients, proper interactions with light. but then when i ram preview it's like it converts it to an 8 bit project, i.e. banding, etc. so the green bar fills up while it's ram previewing, and the ram preview plays with this banding. but then if i stop the ram preview and play with the space bar it shows how i'd expect a 32bit project to look.
weird huh.


Return to posts index


Dave LaRondeRe: 8bit ram previews of 32bit project
by on Apr 21, 2010 at 12:48:00 pm

When you RAM Preview, AE writes to a codec. If you have an 8-bit codec selected as the default for RAM Previewing, that's what it'll use.

Since there are NO 32-bit codecs, you're going to have something of a problem doing what you want.

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

Martin StaceyRe: 8bit ram previews of 32bit project
by on Apr 21, 2010 at 1:55:40 pm

but how comes when it's not in ram preview it can display it properly?
i.e. when it's not ram previewing it looks right. and when i play it by pressing the space bar it looks right. just not when i ram preview.
also it's not like it's rendering it twice, once at 8bit and once at 32bit. it's seems to render it once at 32bit. but when you press ram preview it converts that to 8 bit.
weird.


Return to posts index

Dave LaRondeRe: 8bit ram previews of 32bit project
by on Apr 21, 2010 at 2:10:12 pm

[Martin Stacey] "but how comes when it's not in ram preview it can display it properly?"

Dude, read it again: When you RAM Preview, AE writes to a codec. If you have an 8-bit codec selected as the default for RAM Previewing, that's what it'll use.

Go snoop around in your default Output Module settings and fiddle with 'em.

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index


Martin StaceyRe: 8bit ram previews of 32bit project
by on Apr 21, 2010 at 2:43:24 pm

yeah, i understand that it's an 8 bit codec.
but this is the thing.
when i play it by pressing the space bar it looks correct. the space bar and the ram preview are accessing exactly the same rendered file. it's like it's doing a weird on the fly conversion to 8 bit when i press the ram preview button, but not when i press the space bar. but they are playing the same rendered file.
so a work around would be:
ram preview the timeline to render the sequence.
then stop the banded looking ram preview.
and press the space bar, and get the non banded preview without having to wait for it to render cause it's using the rendered information from the ram preview.
but surely there must be a better way than this.
thanks for the help


Return to posts index

Martin StaceyRe: 8bit ram previews of 32bit project
by on Apr 21, 2010 at 5:50:09 pm

hi ya,
i've been doin some more tests. and i think the problem is to do with having 'Linearize Working Space' turned on.
for some reason when this is turned on, ram preview bands. when it is turned off, still in 32bit depth, sRGB working space and 'Blend Colors Using 1.0 Gamma' turned on ram previews are fine.
Also, i tried turning on 'Hardware Accelerate Compostion, Layer, and Footage Panels' and this seemed to do some banding on the comp window, which made me wonder if when i'm ram previewing it's doing some weird hardware acceleration on the comp window, which doesn't get used if you just press space bar.
am i the only one that get's this? anyone else?
if you wanted to replicate what i'm doing, just create a new comp, 32bit, srgb, linear, and create a white solid on a black background and then blur the white solid. then ram preview and the blur will band like mental. hopefully.
i've tried it on a few computers. what the hells happening?


Return to posts index

Martin StaceyRe: 8bit ram previews of 32bit project
by on Apr 22, 2010 at 9:41:08 am

Also, if i change the output module settings for ram preview to 32bit tiffs, then do a ram preview, then save the ram preview, when i look at the files they look right, i.e. 32bit.
then i bring them into ae, and they look right. then i ram preview them, and again they turn back into 8 bit.
so the ram preview IS doing some weird on the fly conversion to 8 bit, even when the files it is rendering are 32bit.


Return to posts index


Martin StaceyRe: 8bit ram previews of 32bit project
by on Apr 23, 2010 at 8:08:55 am

is this not a problem for anyone else?



Return to posts index

Jon BaggeRe: 8bit ram previews of 32bit project
by on Apr 23, 2010 at 10:22:16 am

What Dave was referring to is that the RAM preview uses a codec. You can change this by going to Edit->Templates->Output Module.

You can change the default RAM preview codec. However I tried doing that to something like OpenEXR sequence (which is supposed to be 32-bit) and the same problem occurs. So I'm not quite sure what else you can do.

You could try and ask on the Adobe forums, some of the staff might know more.



--------------
Jon Bagge
Editor - London, UK
Avid - FCP - After Effects


Return to posts index

Martin StaceyRe: 8bit ram previews of 32bit project
by on Apr 23, 2010 at 12:47:26 pm

yeah, cool thanks.
yeah i tried changing the codec to 32bit tiffs, but that had the same problem.
but the thing is, when i save the ram preview to disk, it's in 32bit tiffs and it looks right. and also when i press the space bar to play the same rendered sequence it looks right. which is why i think that the ram preview is doing some weird kinda of hardware acceleration on it. cause it seems that the files it's rendering are right. just ram preview is doing something weird to them when it plays.


Return to posts index


Tom DurhamRe: 8bit ram previews of 32bit project
by on Nov 29, 2011 at 7:56:45 pm

I have exactly the same issue. Hit play with spacebar, and it plays properly... Play from RAM preview--regardless of codec--and it converts to 8-bit or some other lame sampling for the playback. I think this is just how AE works no matter what.

I'm still on the hunt for the ultimate settings for nice bandless gradients...





================================================
YOU can help save TimeSpace. Join the Chronos Protectorate!

http://www.95ers.com
http://www.SpaceAceMedia.com


Return to posts index

Martin StaceyRe: 8bit ram previews of 32bit project
by on Dec 9, 2011 at 11:33:07 am

Hi, sorry for the late reply, but it seemed to be fixed in AE CS5. there was a new setting in the 'previews' preference. you need to change colour management quality to more accurate.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]