ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Rendering video correctly is harder than it seems in AE CS4

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Ben Shoemate
Rendering video correctly is harder than it seems in AE CS4
on Apr 19, 2010 at 8:27:30 pm

I have a question for the creative community.

I did some rotoscoping in some video files that will be posted on the web and to a dvd but I can not get the quality of the exported video to match the original. Here is what I have done:

1) I import the clip in into AE
2) the project window reports that the original file is mpg format, 528 x 480 (1.21 pixel ratio), Separating (Upper), 29.97 fps, millions of colors, no compression, 48khz / 32 bit / stereo
3) I drag the footage down to the little icon that says create new composition and a black canvas for composition appears. I drag the video footage to the comp and it appears on the timeline.
4) I do some rotoscoping with the paint brush, clone tool, etc...etc...40 hours later, I'm happy with the result.
5) I click Composition > add to render queue
6) I try the default settings: Render Settings= Best Settings; Output Module= Lossless;
7) it makes a huge AVI file, 10 times bigger than the original mpg (fine, I get that) but the quality is not as good. It's got more artifacts, and the details are harder to discern.
8) I try again and again, tweaking render settings and output settings, but I can only make it worse (doing things like adding field render upper or lower add these lines into the part of the movie with motion - so I leave that turned off).

All of the online tutorials recommend exporting from AE as a lossless Quicktime file with the Animiation codec. But even with that I have the same problem - the quality noticeably worse than the original MPG. I even tried taking that Quicktime - Animation - to adobe media encoder and letting it do a 2 pass
9) Sooo...here I am. I registered on this forum and post my question here.

If you have any ideas or recommendations, please, you know, type them up and post them. Thanks.


Return to posts index

Steve Roberts
Re: Rendering video correctly is harder than it seems in AE CS4
on Apr 19, 2010 at 9:00:11 pm

My guess is that the imported MPG (just for fun, search for "Dave's stock answer #1") is actually progressive, not interlaced. So you should select the imported file, and file>interpret footage>main. Then turn off "separate fields" in the interpret footage dialog.



Return to posts index

Ben Shoemate
Re: Rendering video correctly is harder than it seems in AE CS4
on Apr 19, 2010 at 10:00:12 pm

Hi Steve, Thanks for the advice.

I followed you're advice (select the imported file, and file>interpret footage>main. Then turn off "separate fields" in the interpret footage dialog.)

Now as I scrub through the video I see (what I think are called interlace lines) so I found and used this http://www.videocopilot.net/forum/viewtopic.php?f=15&t=9741 to "deinterlace" (man I'm learning a lot of new words today) and the lines went away. Now I'm going to try and re-render and test the quality.

If that works, I'll copy the effects from the old comp to the new one. (fingers crossed)



Return to posts index


Ben Shoemate
Re: Rendering video correctly is harder than it seems in AE CS4
on Apr 19, 2010 at 10:22:32 pm

Stupid question, but is it even possible to get the same quality out of After effects as get put in?

mpg > import into AE > turn off interlacing > render out lossless QT with animation codec

at this point, if I play that video with QT should it look as good as the original mpg? I would think so right? But it is noticeably inferior.

Or should I switch to the strategy Dave suggested, convert the original .mpg (to what though?) before import?


Return to posts index

Steve Roberts
Re: Rendering video correctly is harder than it seems in AE CS4
on Apr 20, 2010 at 12:00:36 am

If you see the combed lines, then it was incorrect to turn off field separation. You had it right the first time: separate fields.

You see, in order to scale, blur and do just about anything to interlaced footage without totally messing things up, AE needs to separate the fields, work your magic, then reintroduce interlacing or not at the render stage (your choice).

Now if you want to do roto, you should separate fields, then do the roto in a 59.94fps comp for 29.97 interlaced footage, or in a 50fps comp for 25 fps interlaced footage. Then drop that comp into a 29.97 (or 25) comp and render that.

Yes, you should convert the MPG to something like a Quicktime in Animation of PNG codec, then import that.




Return to posts index

Ben Shoemate
Re: Rendering video correctly is harder than it seems in AE CS4
on Apr 20, 2010 at 4:14:55 am

Ok - very interesting, I'm learning why they pay you guys the big bucks but getting closer I think.
As per your instructions I have:

1) imported the video
2) right click and select "Interpret Footage" > "Main"
- a dialog appear and says: Separate Fields: Upper Field First
- I change this to "off"
- It says frame rate is 29.97 fps but I leave this alone here (i need to change it in the comp right?
- click ok - close dialog
3) drag footage to create a new composition (called comp 1)
- right click composition change the frame rate to 59.94 fps
- drag footage onto comp 1, as I scrub through it, the motion has combed interface lines
- do a little rotoscoping (now there are twice as many frames - yikes!), some animation, yada yada
4) create a new comp, same settings but frame rate is 29.97 fps
- drag comp 1 to comp 2
- I think this will cause comp 1 to play inside comp 2, as if there is a tv in the shot playing 59 fps but comp 1 is only "recording" 29 fps of them (or something right?)
5) render comp 2
- at this point, no matter how I render it, I still see interlace lines in the final output.
- comp 2 also shows the interlace lines

The good news is the final render is clean as a whistle (expect the lines). In your previous message you said "reintroduce the interlacing or not (your choice)" - but I can't find the choice button...

thanks for getting me this far...


Return to posts index


Ben Shoemate
Re: Rendering video correctly is harder than it seems in AE CS4
on Apr 20, 2010 at 3:40:03 pm

I forgot to add that in the original mpg, it plays on the computer without interface lines showing. But after I render in after effects, it seems I only have two options - crisp (but with interface lines) or no lines but blurrier (if I select progressive scan). Why can't I seem to render it out the same way it came in?

It must be possible since the original video is recognized by AE as interlaced (upper field) and when I interpret the footage and turn it off, I can see the lines.

I just want to find a method that outputs the same quality as I got in...

Which I'm thinking is somehow interlaced, but perhaps tagged so it plays non-interlaced...



Return to posts index

Dave LaRonde
Re: Rendering video correctly is harder than it seems in AE CS4
on Apr 19, 2010 at 9:00:51 pm

Sorry to be the bearer of bad news after all that hard work but......


Dave's Stock Answer #1:

If the footage you imported into AE is any kind of the following -- footage in an HDV acquisition codec, MPEG1, MPEG2, AVCHD, mp4, mts, m2t, H.261 or H.264 -- you need to convert it to a different codec.

These kinds of footage use temporal, or interframe compression. They have keyframes at regular intervals, containing complete frame information. However, the frames in between do NOT have complete information. Interframe codecs toss out duplicated information.

In order to maintain peak rendering efficiency, AE needs complete information for each and every frame. But because these kinds of footage contain only partial information, AE freaks out, resulting in a wide variety of problems.


Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

Steve Roberts
Re: Rendering video correctly is harder than it seems in AE CS4
on Apr 19, 2010 at 9:18:03 pm

Beatcha tuit.



Return to posts index


Dave LaRonde
Re: Rendering video correctly is harder than it seems in AE CS4
on Apr 19, 2010 at 9:40:14 pm

Nice new picture there, pal. Now I'll have to coerce the younger daughter (and professional photog) into a new head shot for me, I guess....

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

Ben Shoemate
Re: Rendering video correctly is harder than it seems in AE CS4
on Apr 19, 2010 at 9:31:07 pm

Ok - I think I understand. Your saying that although AE accepts mpg formats, it doesn't fully support them (i.e. the data between keyframes in the mpg compressed version is lost)...ok. so, let me ask you this. Should I convert the original using Adobe Media Encoder (or some other tool) to change the original (MPG) to some other format before I import into AE? If so, which format? Or should I try to get the original footage in some other format from the producer?

The original plan was:
get mpg > import to After effects (do magic) > export and send mpg

Now it sounds like the plan needs to be:
get mpg > turn mpg in something else (what and how?) > import to AE > render out as lossless quicktime animation > use adobe media encoder to change back to .mpg or mov > send back to producer

or maybe even this:
get mpg > say ".mpg, dude. wtf?" and ask for something else > import to AE > export and send QT .mov

with the same aspect ratio and quality. Did I get that right?



Return to posts index

Dave LaRonde
Re: Rendering video correctly is harder than it seems in AE CS4
on Apr 19, 2010 at 9:38:05 pm

I'm a Mac guy, so I always recommend something in the realm of quicktime, such as the Animation or PNG codecs at best quality: they're both lossless, but PNG files tend to be smaller.

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index


Steve Roberts
Re: Rendering video correctly is harder than it seems in AE CS4
on Apr 20, 2010 at 12:03:04 am

If you can't get a master in a high-quality codec (what are your options?), I'd use QT Player to export to one of the codecs we've mentioned. If it's interlaced, separate fields and roto in a 59.94/50 comp as mentioned, then render interlaced. Check on an interlaced monitor.



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]