ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

After Effect 7 and HDV artifacting

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Win EdsonAfter Effect 7 and HDV artifacting
by on Mar 10, 2010 at 7:55:58 pm

Hi Everyone,

I have After Effects 7.0 at home, and 8.0 at work. When I bring in my raw HDV footage into AE 7 it comes in as

1920x1080 (1.00) square pixels

When I drag this to make it into a comp, there's definite artifacting on the diagonal edges.

When I import the raw HDV footage into AE 8, it brings it as

1440x1080 (1.33) hdv1080 pixels.

When I drag this to make it into a comp, I get the same artifacting,

BUT, if I then change the comp to

1920x1080 Square pixels

It looks sharp as can be (and renders this way)

The obvious thing to do here is to upgrade to AE 8 at home, but my budget doesn't allow me at this time.

Does anyone know if there's any presets I can download to get past this problem?

Anybody experience this?

Thanks in advance for any advice!

Win


Return to posts index

Michael SzalapskiRe: After Effect 7 and HDV artifacting
by on Mar 10, 2010 at 10:02:58 pm

Are you just talking about in your Composition window? Usually when dealing with aspect ratios other than square pixel the aspect ratio correction can make diagonals look funny, but it will look fine when you actually render it out.

Just as an FYI, HDV footage is (almost) always 1440x1080, not 1920x1080.

Also, since you're talking about HDV, you might want to read this from Dave LaRonde:
Dave's Stock Answer #1:

If the footage you imported into AE is any kind of the following -- footage in an HDV acquisition codec, MPEG1, MPEG2, mp4, m2t, H.261 or H.264 -- you need to convert it to a different codec.

These kinds of footage use temporal, or interframe compression. They have keyframes at regular intervals, containing complete frame information. However, the frames in between do NOT have complete information. Interframe codecs toss out duplicated information.

In order to maintain peak rendering efficiency, AE needs complete information for each and every frame. But because these kinds of footage contain only partial information, AE freaks out, resulting in a wide variety of problems.

And Adobe agrees.

I wasn't having any issues with my footage, but I noticed a HUGE increase in my render speed when I started using the proper codec (rather than the "raw HDV").

- The Great Szalam
(The 'Great' stands for 'Not So Great, in fact, Extremely Humble')

No trees were harmed in the creation of this message, but several thousand electrons were mildly inconvenienced.


Return to posts index

Win EdsonRe: After Effect 7 and HDV artifacting
by on Mar 10, 2010 at 11:30:36 pm

Thanks Michael for your response and info.

My raw HDV footage is definitely 1440x1080 (Canon A1) that's why it's weird that After Effects 7 is interpreting it as 1920x1080, and probably the root of my problem. But I don't know of a way of changing how my AE interprets/imports the footage. I've tried using 'command F' and looking at my options there, but there's no way to change the frame size, only pixel ratio (and field dominance etc)

Unfortunately my renders exhibit the same diagonal artifacting as my previews in the Composition window.

My After Effects 8 interprets the footage as the proper 1440x1080. It just seems version 8 is smarter than 7, which makes sense, but I'm still hoping for a work around.

Thanks again.

Win


Return to posts index


Michael SzalapskiRe: After Effect 7 and HDV artifacting
by on Mar 11, 2010 at 3:01:09 pm

I maintain that you shouldn't be working with "raw HDV" footage in AE. Encode it as something else before you bring it in. That should eliminate all your issues.

- The Great Szalam
(The 'Great' stands for 'Not So Great, in fact, Extremely Humble')

No trees were harmed in the creation of this message, but several thousand electrons were mildly inconvenienced.


Return to posts index

Win EdsonRe: After Effect 7 and HDV artifacting
by on Mar 11, 2010 at 8:44:57 pm

Thanks a million Michael that worked.

By exporting the raw HDV file from Quicktime Proto the Apple Intermediate Codec, then bringing that into After Effects, solved the artifacting problem. And the apple codec only doubled the file size, which isn't bad really.

I did notice that the contrast had been reduced greatly, so I'm going with the uncompressed option, yeah, the file sizes are huge, but there's no contrast/brightness shift.

Either way, my renders are super sharp.

Thanks again!

Win


Return to posts index


Michael SzalapskiHooray!
by on Mar 11, 2010 at 9:25:33 pm

No problem! Glad to help. Feel free to mark the post as a Solution, so people know this thread is solved. Most people forget to do that.

- The Great Szalam
(The 'Great' stands for 'Not So Great, in fact, Extremely Humble')

No trees were harmed in the creation of this message, but several thousand electrons were mildly inconvenienced.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]