ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Shadow Casting Problems

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Eric Goldstein
Shadow Casting Problems
on Feb 23, 2010 at 12:00:42 am

Hi,

I have a comp - everything is 3D. there's an object I built sitting on a floor. The object is made of two precomps. I can't get it to cast a shadow in the camera view. I've checked that all materials I want to cast shadows have shadow casting turned on. I've checked collapse transform where necessary. The strange thing is that the shadow shows up properly in the custom views. Any idea what this might be about?

Thanks,

Eric


Eric Goldstein
Giraffe Film Company
Los Angeles
eric@giraffefilm.com


Return to posts index

Eric Goldstein
Re: Shadow Casting Problems
on Feb 23, 2010 at 12:28:17 am

Also, the cube, which is the object I've got in the scene isn't drawing correctly in the camera view; the top is missing. It is drawing correctly in the custom view...

Thanks again,

Eric


Eric Goldstein
Giraffe Film Company
Los Angeles
eric@giraffefilm.com


Return to posts index

Joey Foreman
Re: Shadow Casting Problems
on Feb 23, 2010 at 2:51:52 am

How about some screencaps?


Return to posts index


Eric Goldstein
Re: Shadow Casting Problems
on Feb 23, 2010 at 3:06:45 am

Hi Joey,

What do you mean by screen caps?


Eric

Eric Goldstein
Giraffe Film Company
Los Angeles
eric@giraffefilm.com


Return to posts index

Joey Foreman
Re: Shadow Casting Problems
on Feb 23, 2010 at 3:12:11 am

Screen Captures. "Snapshots" of your screen
so we can see the problems you're describing.


Return to posts index

Eric Goldstein
Re: Shadow Casting Problems
on Feb 23, 2010 at 6:53:49 am

Okay, sorry to be slow.

Here's the active camera view (No shadow, top of block missing:



Here's the custom view with no changes (Shadow in place, top of block in place:



Thanks,

Eric



Eric Goldstein
Giraffe Film Company
Los Angeles
eric@giraffefilm.com


Return to posts index


Joey Foreman
Re: Shadow Casting Problems
on Feb 23, 2010 at 3:07:35 pm

Thanks, Eric. Actually I also wanted to see your entire AE UI so I can look at your layers as well.



Return to posts index

Eric Goldstein
Re: Shadow Casting Problems
on Feb 23, 2010 at 3:38:46 pm

Hi Joey,

Here are screen shots with the full UI. The first is the final comp. The second is the PreComp for the cube where I've assembled the sides and feeds the main comp. The third is the construction of the sides that feeds all the cube assembly comp. Thanks again for your help, Eric.

Main Comp:


Assemble Cube Comp:



Assemble Side Comp:









Eric Goldstein
Giraffe Film Company
Los Angeles
eric@giraffefilm.com


Return to posts index

Eric Goldstein
Re: Shadow Casting Problems
on Feb 23, 2010 at 6:36:11 pm

Just as a note, I turned off shadow casting properties in a number of layers and that solved the problem, but I'm surprised. I've got a Quad Core Intel with 6GB RAM. I've done more shadow casting layers with greater resolution on a G4 Mac with 2GB RAM...

Eric Goldstein
Giraffe Film Company
Los Angeles
eric@giraffefilm.com


Return to posts index


Dave LaRonde
Re: Shadow Casting Problems
on Feb 23, 2010 at 6:41:53 pm

[Eric Goldstein] "I've got a Quad Core Intel with 6GB RAM. I've done more shadow casting layers with greater resolution on a G4 Mac with 2GB RAM... "

You probably ought to read the following.......

http://blogs.adobe.com/toddkopriva/2009/12/performance-tip-dont-starve-yo.h...


Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

Eric Goldstein
Re: Shadow Casting Problems
on Feb 23, 2010 at 6:49:25 pm

Thanks, Dave.

I guess I better go to the RAM store.

Eric


Eric Goldstein
Giraffe Film Company
Los Angeles
eric@giraffefilm.com


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]