ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Black bars when exporting as WMV?

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Sam BellBlack bars when exporting as WMV?
by on Feb 17, 2010 at 6:03:12 am

Hi,
This is the first time I've tried exporting my composition to WMV format using the Render Queue,
so please forgive me if I'm doing something wrong. Couldn't find an answer in the forums.

The problem is I'm getting black bars on the left and right sides of the exported video.

I do not get black bars when I export to Quicktime format. And there are no black bars in
my composition, of course. They are being created on export by WMV.

Settings:
Format: Windows Media
Stretch: None
Crop: None

Pixel Aspect Ratio: Square pixels
Frame Rate: 24fps
Image Quality: 100
Max Bitrate: 1088 Kbps
Video size: 856x480


What I don't understand is this comment pops up in one of the dialogs:
"Set frame size to 320 x 240 pixels in the Stretch options in Output Module before encoding."

Do I have to stretch my video to a certain aspect ratio to get it fill in the sides with WMV?


Return to posts index

Walter SoykaRe: Black bars when exporting as WMV?
by on Feb 17, 2010 at 3:58:12 pm

It sounds like there is a frame size mismatch somewhere in your compression settings.

After Effects is not a great compression application. It's incapable of multi-pass compression, which generates much cleaner WMV files.

A better workflow is to render lossless animations from AE and bring them into a third-party compression application, like Telestream Episode or Sorenson Squeeze. If you are on a PC, you can use Microsoft's free WMV encoder.

Walter Soyka
Principal & Designer at Keen Live
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
RenderBreak Blog - What I'm thinking when my workstation's thinking
Creative Cow Forum Host: Live & Stage Events


Return to posts index

Sam BellRe: Black bars when exporting as WMV?
by on Feb 17, 2010 at 5:23:26 pm

Thanks for the reply, but the frame size is automatically retrieved from the composition settings.
The only way to change it on output is to stretch it.

Well, just for the fun of it, I entered the "suggested" frame size of 320x240 pixels in the Stretch option,
and rendered out a quick 5 seconds...and I still get black borders on the left/right sides.

And I've tried MS WMV Encoder, but it's very picky about the audio/video formats it will convert.
It will quit halfway if it doesn't like the audio for any reason. Going through a lossless format
doubles the render time and I don't want to deal with large files in the GBs.

Just need a good WMV exporter that does what you tell it to do. :)


Return to posts index


Walter SoykaRe: Black bars when exporting as WMV?
by on Feb 17, 2010 at 6:31:33 pm

[Sam Bell] "Well, just for the fun of it, I entered the "suggested" frame size of 320x240 pixels in the Stretch option, and rendered out a quick 5 seconds...and I still get black borders on the left/right sides."

Does your comp perhaps use rectangular pixels instead of square ones?

[Sam Bell] "Going through a lossless format doubles the render time and I don't want to deal with large files in the GBs. Just need a good WMV exporter that does what you tell it to do. :)"

The workflow you're looking for is certainly a little more convenient, but you're sacrificing a lot of quality. AE cannot do multipass compression, which would help reduce compression artifacts like blocking and banding, and keep file sizes low. It's really important for high-quality WMV and h264 media, which is why most folks here recommend using a third-party encoder.

Walter Soyka
Principal & Designer at Keen Live
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
RenderBreak Blog - What I'm thinking when my workstation's thinking
Creative Cow Forum Host: Live & Stage Events


Return to posts index

Sam BellRe: Black bars when exporting as WMV?
by on Feb 17, 2010 at 6:55:49 pm

Thanks, that was it! My composition settings was set to D1/DV NTSC (0.91) by accident.
I changed it to square pixels and rendered out to WMV...and it worked! No black bars on the side.

Thanks for the help!


Return to posts index

Michael SzalapskiRe: Black bars when exporting as WMV?
by on Feb 17, 2010 at 7:52:55 pm

Glad it's working.
Seriously though, listen to him. Export a lossless video from AE and use Adobe Media Encoder or something else to actually create the WMV; you'll get a better looking video in a smaller file size.

- The Great Szalam
(The 'Great' stands for 'Not So Great, in fact, Extremely Humble')

No trees were harmed in the creation of this message, but several thousand electrons were mildly inconvenienced.


Return to posts index


Tim DillRe: Black bars when exporting as WMV?
by on Sep 28, 2011 at 2:33:34 pm

I am getting these black bars as well when I view my video in my video player online. The movie was made 720x480 but I reduce it to 500x333,which is proportionate, but still get the bars. How do you go about changing the pixel type? I want to try this and see if it works for my issue as well. I looked for it but AE is vast and I didn't find anything that was related.

Thanks!


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]