ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Pieces of 3D building disappear on export?

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Charles FerranPieces of 3D building disappear on export?
by on Jan 26, 2010 at 4:22:16 pm

the pics I've attached show what I'm talking about, in the first frame, the buildings base is intact, in the next frame, a piece of it disappears, it's hard to see from the jpegs but watching it fly through, its glaring. I'm flying a camera down a road and going into this building. Other things do it subtly as well, like the sides of other buildings seem to flicker and overlap. They only do this on the export though, in After Effects it looks perfect... So what's going on here? I know I'm bending After Effects to do something it really wasn't designed to do, and I should expect some trouble, but is there a way to fix this, or fake it? the whole thing is fake 3D, I might as well fake a solution :)




Charles Ferran
845-699-5270
http://www.charlesferran.com

"Far better is to dare mighty things, to win glorious triumphs, even though checkered by failure than to rank with the poor spirits who neither enjoy much, nor suffer much because they live in a gray twilight that knows no victory or defeat."



Return to posts index

Dave LaRondeRe: Pieces of 3D building disappear on export?
by on Jan 26, 2010 at 4:32:38 pm

Okay, let's get the obvious suspects out of the way.

When you put the 3D comp together, did you make sure you looked at it using the Active Camera and not a Custom View?

Did you try to use Open GL for rendering, which almost always does more harm than good?

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

Charles FerranRe: Pieces of 3D building disappear on export?
by on Jan 26, 2010 at 4:44:06 pm

well, I don't know if its because I turned off OpenGL, but I now see that flicker in the jpegs, in my timeline, so that's a step! (I guess?)

...AHA when I turn on Draft 3D the problem goes away, so what exactly is Draft 3D effecting? I'm assuming therein lies the problem...

Charles Ferran
845-699-5270
http://www.charlesferran.com

"Far better is to dare mighty things, to win glorious triumphs, even though checkered by failure than to rank with the poor spirits who neither enjoy much, nor suffer much because they live in a gray twilight that knows no victory or defeat."



Return to posts index


Charles FerranRe: Pieces of 3D building disappear on export?
by on Jan 26, 2010 at 4:48:26 pm

also, the flickering building layers are fixed as well under Draft 3D...hmmm

Charles Ferran
845-699-5270
http://www.charlesferran.com

"Far better is to dare mighty things, to win glorious triumphs, even though checkered by failure than to rank with the poor spirits who neither enjoy much, nor suffer much because they live in a gray twilight that knows no victory or defeat."



Return to posts index

Charles FerranRe: Pieces of 3D building disappear on export?
by on Jan 26, 2010 at 5:05:26 pm

Here's another example:

Draft 3D Off (BOO):

Draft 3D On (YAY):



Charles Ferran
845-699-5270
http://www.charlesferran.com

"Far better is to dare mighty things, to win glorious triumphs, even though checkered by failure than to rank with the poor spirits who neither enjoy much, nor suffer much because they live in a gray twilight that knows no victory or defeat."



Return to posts index

Charles FerranRe: Pieces of 3D building disappear on export?
by on Jan 26, 2010 at 5:11:57 pm

and, when I solo a building with Draft 3D off, the problem goes away with that building, but if I un solo it, problems back... I'm starting to think maybe my camera has something to do with it?

Charles Ferran
845-699-5270
http://www.charlesferran.com

"Far better is to dare mighty things, to win glorious triumphs, even though checkered by failure than to rank with the poor spirits who neither enjoy much, nor suffer much because they live in a gray twilight that knows no victory or defeat."



Return to posts index


Aled Rhys JonesRe: Pieces of 3D building disappear on export?
by on Jan 26, 2010 at 5:16:30 pm

Hi Charles, I too have tried to push AE as far as it can go re 3D and had similar problems.

I think it's something that Adobe haven't seemed to fix for a long time. Here's some considerations/fixes though:

If your layers contain alpha channels - make sure they don't lie on the same plane as any other layer.

e.g. In photoshop you have your buildings bricks texture as one layer, windows on another layer above it; when this is brought in to AE - put the tiniest bit of space between them (perhaps 1-5 pixels in Z).

Switch off Motion Blur - I think this is the biggest culprit. Render out the movie and add a Motion Blur effect instead (I know it might not look quite how you'd like it; perhaps you can get away with switching off the MB for the bugged layers only?)

There are some other fixes I might know of - I'll try to update this thread as and when they come to me.

Hope it helps.

Regards,
Aled





Aled Rhys Jones

VFX & GFX Senior Designer

wipgfx.com

Dublin, Ireland



After Effects Consultancy | Motion Graphics | Compositing | Video Effects



Return to posts index

Charles FerranRe: Pieces of 3D building disappear on export?
by on Jan 26, 2010 at 5:26:58 pm

HEY THANKS, I'M RENDERING, SORRY FOR CAPS :) ANYWAY, I FOUND A KIND OF WORKAROUND, I LOWERED THE FOCUS DEPTH ON MY CAMERA, WHICH SEEMED TO FIX IT, WHEN ITS DONE RENDERING I'LL REPORT, IT WILL TAKE AWHILE, WORKING ON 2 GBS OF RAM O_O I REALLY NEED TO GET INTO CINEMA 4D, BUT I WOULD LOVE ANY MORE HINTS YOU MAY HAVE BECAUSE I'VE COMMITTED MYSELF TO ABOUT 3 MORE OF THE HEAVY 3D ANIMATIONS IN AFTER EFFECTS.

Charles Ferran
845-699-5270
http://www.charlesferran.com

"Far better is to dare mighty things, to win glorious triumphs, even though checkered by failure than to rank with the poor spirits who neither enjoy much, nor suffer much because they live in a gray twilight that knows no victory or defeat."



Return to posts index

Aled Rhys JonesRe: Pieces of 3D building disappear on export?
by on Jan 26, 2010 at 6:00:35 pm

Now - to anyone else (ahem... Adobe - you listening?!) here's what I'm able to replicate which I'm pretty sure that Charles is having problems with:



and:



Am I right in suggesting these are the same problems Charles?





Aled Rhys Jones

VFX & GFX Senior Designer

wipgfx.com

Dublin, Ireland



After Effects Consultancy | Motion Graphics | Compositing | Video Effects



Return to posts index


Charles FerranRe: Pieces of 3D building disappear on export?
by on Jan 26, 2010 at 6:09:14 pm

lol, yes, the first one, I had that problem and fixed it, like you said, I had to move the layers off of each other, now the second one, my problem is similar, but goes away when I turn off certain FX, I'm going to try re-exporting with no motion blur like you suggested and see how that turns out...

Charles Ferran
845-699-5270
http://www.charlesferran.com

"Far better is to dare mighty things, to win glorious triumphs, even though checkered by failure than to rank with the poor spirits who neither enjoy much, nor suffer much because they live in a gray twilight that knows no victory or defeat."



Return to posts index

Charles FerranRe: Pieces of 3D building disappear on export?
by on Jan 26, 2010 at 6:19:54 pm

switching off motion blur does nothing in the timeline, my motion blur was only affecting the road my camera was traveling down since AE won't let me turn motion blur on for my building comps... I'm gonna render one out with now FX whatsoever and see what happens, here i go!!!

Charles Ferran
845-699-5270
http://www.charlesferran.com

"Far better is to dare mighty things, to win glorious triumphs, even though checkered by failure than to rank with the poor spirits who neither enjoy much, nor suffer much because they live in a gray twilight that knows no victory or defeat."



Return to posts index

Charles FerranRe: Pieces of 3D building disappear on export?
by on Jan 26, 2010 at 9:03:08 pm

just an update for whoever is interested, still have the same problem, I was able to fake it by knocking down the focus on the camera to very low so you couldn't see the problems because they were blurred out, BUT when I go to render I crash AE every time, so I think I am going to have to render out a version with no depth of field, then fake the depth of field on a video file version. But that's a question for another day, for now, back to something a tad easier, moving words around :) till next time...

Charles Ferran
845-699-5270
http://www.charlesferran.com

"Far better is to dare mighty things, to win glorious triumphs, even though checkered by failure than to rank with the poor spirits who neither enjoy much, nor suffer much because they live in a gray twilight that knows no victory or defeat."



Return to posts index


Walter SoykaRe: Pieces of 3D building disappear on export?
by on Jan 26, 2010 at 10:31:37 pm

Check out my recent post on how to render to image sequences -- when your render fails, you can re-start it where it left off.

Walter Soyka
Principal & Designer at Keen Live
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
RenderBreak Blog - What I'm thinking when my workstation's thinking
Creative Cow Forum Host: Live & Stage Events


Return to posts index

Charles FerranRe: Pieces of 3D building disappear on export?
by on Jan 27, 2010 at 2:55:39 pm

very good, thanks Walter, back into this today, I will be following your advice in that thread...

Charles Ferran
845-699-5270
http://www.charlesferran.com

"Far better is to dare mighty things, to win glorious triumphs, even though checkered by failure than to rank with the poor spirits who neither enjoy much, nor suffer much because they live in a gray twilight that knows no victory or defeat."



Return to posts index

Jurij MagogaRe: Pieces of 3D building disappear on export?
by on Jun 10, 2010 at 7:04:56 pm

I' ve got the same problem building up a comp with 3d layers in Draft 3d.
The workaround i've found is to export leaving Draft 3d enabled and full resolution, changing the render setting>quality from "best" to "current settings".

Another possible way (if you have enough ram) could be to RAM PREVIEW the whole comp, the go to COMPOSITION>Save Ram Preview.





Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]