ADOBE AFTER EFFECTS: Forum Expressions Tutorials Podcasts Creative Cloud

Keylight causing noise.

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Danny WinnKeylight causing noise.
by on Jan 14, 2010 at 8:08:45 pm

I have read several previous posts on this topic but most were a few years old.

I've keyed out some really great greenscreen shots using the Clip Black/White screen matte technique but those same great keying settings has caused moving noise in the black suit of the actor.

Changing the Clip settings isn't an option, they need to stay where they're at for the awesome key result in. Has anyone developed a quicker technique (other than the duplicate each clip and matte out) to combat the added noise with a fancy color correcting trick or other? The "Noise reduction" effect doesnt look great, besides it seems that you can't set it to a full HD frame.

Any new techniques for this?


Return to posts index

Dave LaRondeRe: Keylight causing noise.
by on Jan 14, 2010 at 8:23:13 pm

Here, read this:

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA

Return to posts index

Danny WinnRe: Keylight causing noise.
by on Jan 15, 2010 at 1:22:51 am

Hey Dave,

I tried doing what was written in the link you provided but when I opened the upper layer Track Matte mode it only gave me options to select a different clip that was above the upper layer, not the layer below that it was duplicated from.

Am I missing something here?

Here's what the link says:

"• Duplicate the keyed footage, and turn off the upper layer.

• Fool with the lower layer's Keylight settings until it looks like the subject looks fine, but is over a grayish, washed-out chroma key background. It'll take some doing, but you will have gotten it to the point where Keylight's spill suppressor is working. That's good, because the Keylight spill suppressor works darned well.

• Open the Modes panel, and use the upper layer as an Alpha Matte for the lower layer. For more info, look up Track Mattes in AE Help.

Poof! You're done! You have a clean key, AND you have spill suppression."

Return to posts index

Ben Heusner BrownleeRe: Keylight causing noise.
by on Jan 15, 2010 at 3:37:40 pm

Hi Danny,

The track matte always looks to the layer above. If you're following that guide, you should be working on the bottom layer, then take the alpha channel from your untouched key (the top layer).

Another thing you can do instead of duping layers is turn Keylight to "Intermediate" and use a regular Spill Suppressor filter afterwards.

Hope that helps,

Curious Turtle Pro Video
Training | Editing | Support
Out Now - Film Wash Color Effects Vol. 3
& Mocha training for AE & FCP

Return to posts index

Danny WinnRe: Keylight causing noise.
by on Jan 15, 2010 at 8:17:55 pm

Very cool Ben, thanks I'll try that;)

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 All Rights Reserved