ADOBE AFTER EFFECTS: Forum Expressions Tutorials Podcasts Creative Cloud

Spacial Keyframe Question

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Matt HopkinsSpacial Keyframe Question
by on Jan 4, 2010 at 6:14:14 pm

I'm struggling with getting smooth motion on my Particular layer. The emitters position is linked with expressions to the animation output from Cinema 4D. So there is a keyframe on each frame.

At one specific point, the null does a loop and it seems there simply aren't enough keyframes for the speed of the loop to get smooth motion. I hope I'm explaining this in an understandable way. See the below link for a screen shot that I feel helps illustrate the problem.

I'm looking for solutions to this issue inside of After Effects. These particles need to match the animation of a animated 3D pipe inside of Cinema 4D. The animated pipe does make the turn smoothly, so I'm left to assume that there is a problem with the translation between C4D and AE.

Thanks in advance for any guidance you can provide.


Matt Hopkins

Return to posts index

Bartek SkorupaRe: Spacial Keyframe Question
by on Jan 4, 2010 at 7:09:46 pm

There is nothing wrong with importing data from Cinema. That's just the way it is.
You just get the information about position on the frame. There is no information about what position the object should have between frames. The interpolation you have on the path is made by AE. Cinema has nothing to do with it.
There are 2 ways of solving it:
1. Adjust the handles manually (without changing the position of keyframes) and in particular in the Emitter section you have the "Position subframe". Change it to "10x Linear" or "10x Smooth" or "Exact".
You will have to tweak it a bit.

2. In Cinema double the number of frames and export again to have more data for AE to play with.

I'd suggest the first option, because you have this problem only at this point of time.

Bartek Skorupa
Warszawa, Poland

Return to posts index

Matt HopkinsRe: Spacial Keyframe Question
by on Jan 5, 2010 at 12:07:30 am

Thanks for your suggestions, Bartek. Adjusting the handles to improve the curve isn't doing much for me. I think you must have Particular 2. My install of the original Particular doesn't have the Positive Subframe attribute. I'm going to shoot for option 3 and try rendering 60 FPS to see if that gives AE enough data to create smoother motion.

Thanks again!

Matt Hopkins

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 All Rights Reserved