ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Incorrect Duration for Imported Audio

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
James BakerIncorrect Duration for Imported Audio
by on Nov 22, 2009 at 11:27:00 am

Hi,

I am using After Effects 7.0 in a 1024 x 576 PAL composition and am having a problem with imported audio.

I have a jpeg sequence at 25 frames per second lasting about two and a half minutes. I have a wav file matching the video/jpegs. The two are exactly the same length; to the frame. However when I import the audio it comes out about 6 frames longer than the original; long enough to skew the whole allignment. This is in the imported file before it has even been added to the timeline. However it is still incorrect in the timeline as well. This mismatch gets larger with longer audios and isn't specific to this file.

I have looked in the preferences and other settings but cannot see why this is the case. Does anyone know or have any ideas about why this might be?

I have heard that After Effects isn't great with audio but a mismatch like that is pretty bad. Is this a known aspect of After Effects 7.0?

If anyone has any ideas I'd be very grateful.

Thanks
James



Return to posts index

David JohnsonRe: Incorrect Duration for Imported Audio
by on Nov 22, 2009 at 2:17:42 pm

It's not really an AE issue ... the issue is that audio files are often generated with time calculations other than timecode, which is what video software like AE reads.

You might try bringing your audio files into audio software, looking at the actual lengths and using that audio software to trim them to the desired timecode lengths ... most audio software has an option for timecode, but it is typically not the default in audio software.

By the way, AE doesn't really have issues with audio in general ... it sometimes doesn't play nicely with mp3 audio since it is really intended to work with raw media.


Return to posts index

James BakerRe: Incorrect Duration for Imported Audio
by on Nov 23, 2009 at 8:20:09 am

Thanks for help,

I am still a bit confused by a couple of things. I know this isn't completely an After Effects issue but if you have an more ideas about this I'd be grateful.

I have been working between flash 8 and After Effects. The wav audio that I described comes out at different lengths in the two different programs. I know that flash does not technically use timecode but you can see via the number of frames whether it is the same or not. Do you have any idea why this may be. I will try posting on the flash forum as well.

Also when I import the wav file into AE; before it is placed in the timeline the timecode reads differently to when it is placed in the timeline. The timeline is PAL 25 frames and the import also 25 frames. Just for my undrstanding do you know what the wav file is basing its timecode on?

Thanks
James


Return to posts index


Dave JohnsonRe: Incorrect Duration for Imported Audio
by on Nov 23, 2009 at 4:53:13 pm

Perhaps I misunderstood the issue ... I thought you were just referring to why a 10-second audio file will often show as slightly longer than 10 seconds in AE. Someone more versed with Flash than I can help more ... this is all I can gather about what you describe...

[James Baker] I have been working between flash 8 and After Effects. The wav audio that I described comes out at different lengths in the two different programs.

AE is frame-accurate, but I don't know that Flash is (or how it could be if it doesn't use timecode in the strict sense), but that should only result in a few extra frames at the end of an audio file in the AE timeline, which shouldn't affect synch.


[James Baker] Also when I import the wav file into AE; before it is placed in the timeline the timecode reads differently to when it is placed in the timeline.

Sorry, but I don't know about this one ... the only way I'd expect AE to possibly show slightly different times for the same audio file is if there were something unusual about the project settings or comp settings the imported file is in or if there were something wrong with the way the file was interpreted upon import.


Return to posts index

James BakerRe: Incorrect Duration for Imported Audio
by on Nov 24, 2009 at 10:51:09 am

Thanks for both of your advice. I have checked and the sampling rate was originally 44.1 HZ.

Sorry for the confusion; I think this is almost definitely a flash issue. I will post on the relevant forum.

Even though flash 8 doesn't use timecode specifically it shows the exact number of frames at a specific frame rate. This should make it as specific as timecode. Shouldn't it?
Also the mismatch was out by 6 frames. At 25 frames per second this is more than enough to make something look hugely out of sync if only towards the end of the work.


Return to posts index

Dave LaRondeRe: Incorrect Duration for Imported Audio
by on Nov 23, 2009 at 4:56:45 pm

Here's another thing to check: the audio sampling rate. It could be that the original audio has a 48kHz sampling rate, but AE is set up for 44.1 kHz.

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index


Sagi GreenRe: Incorrect Duration for Imported Audio
by on Sep 16, 2013 at 7:03:29 pm

Hi,

your solution will be bit depth - change it from 16 to 24/32
or just import file as mp3 that usualy get the bit rate stuff out of the way,

good luck

Sagi Green
Crazy Designs Co-founder and VP Business Development
http://www.crazydesigns.biz


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]