ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Multiprocessing with dynamic link - Premiere to After Effects

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Paul BinnsMultiprocessing with dynamic link - Premiere to After Effects
by on Oct 25, 2009 at 2:42:05 am

I am rendering some HDV premiere sequences in after effects and am finding that when I go to render with multiprocessing on, after effects will give a message saying 'incompatible effect or expression, multiprocessing is switched off'.

Has anyone got any clues as to why this is happening and what can I do to take advantage of both processors in my Imac core2duo 2.4 (4 gig ram)?


Return to posts index

Todd KoprivaRe: Multiprocessing with dynamic link - Premiere to After Effects
by on Oct 26, 2009 at 3:54:22 am

Here's a list of reasons for After Effects disabling Render Multiple Frames Simultaneously multiprocessing.

But, in general, if you're running both After Effects and Premiere Pro at the same time (as you are with Dynamic Link), then 4GB isn't much memory, and you're probably better off not trying to use Render Multiple Frames multiprocessing.

---------------------------------------------------------------------------------------------------------
Todd Kopriva, Adobe Systems Incorporated
putting the 'T' back in 'RTFM' : After Effects Help on the Web
---------------------------------------------------------------------------------------------------------
If a page of After Effects Help answers your question, please consider rating it. If you have a tip, technique, or link to share---or if there is something that you'd like to see added or improved---please leave a comment.


Return to posts index

Paul BinnsRe: Multiprocessing with dynamic link - Premiere to After Effects
by on Oct 26, 2009 at 4:17:41 am

Hi Todd

thanks for the answer. Ok to follow up on that, I notice that while it is rendering, that after effects is only using between 50-70% of the CPU, not 100% - this is despite there being nothing else running on the computer. Is there any reason for this that I can fix to get it to use more?

I have also found that generally when rendering stuff out on this computer that dual-processing actually creates longer render times than with it on - any suggestions on how to set after effects multi-cpu preferences to take advantage of the dual-cpu's?


Return to posts index


Todd KoprivaRe: Multiprocessing with dynamic link - Premiere to After Effects
by on Oct 26, 2009 at 8:38:46 pm

> I notice that while it is rendering, that after effects is only using between 50-70% of the CPU, not 100% - this is despite there being nothing else running on the computer. Is there any reason for this that I can fix to get it to use more?

I have also found that generally when rendering stuff out on this computer that dual-processing actually creates longer render times than with it on - any suggestions on how to set after effects multi-cpu preferences to take advantage of the dual-cpu's?


I encourage you to think about this a bit differently. Don't think in terms of trying to peg your CPU usage at 100%. Think of the goal being getting work done faster. Here's an excerpt from the page that I pointed you to earlier:

"Using the Render Multiple Frames Simultaneously multiprocessing feature does not speed up the rendering of all compositions. The rendering of some compositions is memory-intensive, such as when you are working with very large background plates that are several thousands of pixels tall and wide. The rendering of some compositions is bandwidth-intensive (I/O-intensive), such as when you are working with many source files, especially if they are not served by a fast, local, dedicated disk drive. The Render Multiple Frames Simultaneously multiprocessing feature works best at improving performance when the resource that is most exercised by the composition is CPU processing power, such as when applying a processor-intensive effect like a glow or blur."

So, if your CPU isn't the bottleneck, then you're not going to see it pegged at 100%, and turning on Render Multiple Frames Simultaneously multiprocessing isn't going to help.

There are a lot of suggestions for improving performance on this page. For example, one of the recommendations (paraphrased) is "install more RAM".

---------------------------------------------------------------------------------------------------------
Todd Kopriva, Adobe Systems Incorporated
putting the 'T' back in 'RTFM' : After Effects Help on the Web
---------------------------------------------------------------------------------------------------------
If a page of After Effects Help answers your question, please consider rating it. If you have a tip, technique, or link to share---or if there is something that you'd like to see added or improved---please leave a comment.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]