ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Octomac Render Slows Down

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Matt Cooper
Octomac Render Slows Down
on Oct 20, 2009 at 7:21:58 pm

Hi everyone, I hope someone can make sense of my rendering issues.

My computer is a new Octo Mac, 2.66, 16GB RAM, running Snow Leopard, and After Effects 9.02. All of my footage is stored on an external RAID 0 connected through eSATA. My render is saving to a FW800 connected RAID 5. Multiprocessor rendering is turned on, currently set to 2GB per processor (more on this later).

When I start rendering the aeselflink processes start up and load up the RAM they need and my render starts a few moments later. I look inside Activity Monitor as the render starts and I notice something interesting. My render is going at a quick pace, at the same time my Free memory starts getting used up rather rapidly. Then the Free memory gets down to under 100MB (right now sitting at 7.4MB after starting at over 10GB, Inactive is at 5GB) and the render grinds to a halt. Activity monitor shows 6 instances of aeselflink (as that is how many processors I told it to use for this particular render) and each process has anywhere from 1.64GB to 1.70GB (Virtual memory ranges from 2.02GB to 2.09GB) of Real memory usage. The % of CPU used of all processes right now are from 0.1% to 6%, sometimes individual ones will jump up to around 40-60% but then will drop back down. When the render started it said it would take 20 minutes, it's now up to an hour and a half and will probably keep rising as only 4% of my entire processing power is being used.

I have tried adjusting the amount of RAM for multiprocessing from .5GB (too low I know) all the way to 2.09GB. I have also tried adjusting the number of processors for it to use/leave free.

While writing this I stopped the render, quit all the aeselflink processes and rendered again. Multiprocessing was still on but it didn't restart the processes. I was able to get about 30-40% of my entire CPU resources used. The actual After Effects process showed it used up to 465% of the CPU. That render finished, I shut down After Effects, restarted it, and am rendering again, this time the aeselflink processes reloaded and I'm getting the slow speeds again.

Any clue on what I can do to speed things along?


Return to posts index

Theo Veltman
Re: Octomac Render Slows Down
on Oct 21, 2009 at 5:02:59 am

Haha.

I didn't even have to read your whole post to know exactly where you're coming from. I've had exactly the same thing over the past few months. I initially thought it was something to do with the complexity of my project (16bit HD1080) and like you I've tried all the variations on processors and memory. For a start you don't have to close After effects to get all your aeselflink processors back. Just turn off multiprocessing in the preferences, click ok then turn multiprocessing back on and they'll restart. I found the slowdown had something to do with the aeselflink processes reaching there memory capacities i.e. 2.85GB or so (I also got down to 2-10mb free memory on every render) and don't worry about the inactive memory it's still being used by the applications (I won't bother explaining but it's not wasted memory). I couldn't find any way of limiting the amount of memory each process used to stop them exceeding there limits so I ended up babysitting my renders over night. Doing 25 frames then stopping the render just before they hung so the instances would purge the memory they were using (and I wouldn't have to force quit them and do the turn off multiprocessing trick I mentioned) then doing another 25 frames. The best way I've come up with as a work around for this and also just to make better use of the systems resources is to turn multiprocessing of and instead run multiple instances of After Effects (Right click on the Adobe After Effects CS4.app and go show package Contents, Contents/MacOS/After Effects). I've found this the best way of using as many of the systems resources at one time as possible. I run up to six instances this way and let the OS look after the resource management. I'm not holding out any hope Adobe will be releasing a decimal update for CS4 that will help with this as I'm sure it's would require more work than it's worth at this point to address. I'm sure that it's something there keenly aware of with regards to CS5 though (so hurry up early-mid next year). Hope this helps.


Return to posts index

Walter Soyka
Re: Octomac Render Slows Down
on Oct 21, 2009 at 12:44:39 pm

What format is your footage in?

You mentioned that the render starts quickly, then slows down. Is there a particular point in your render where you notice it slowing down dramatically?

Walter Soyka, Principal
Keen Live, Inc.
Presentation, Motion Graphics & Widescreen Design
RenderBreak: A Blog on Innovation in Production



Return to posts index


Matt Cooper
Re: Octomac Render Slows Down
on Oct 21, 2009 at 10:29:56 pm

Theo: Are you saying run multiple instances so you can render multiple comps at once or are you saying by having multiple open it is supposed to help the speed of the one render?

Walter: There is no video in the piece. It is all graphics I have created and some moves on pictures. Not a lot of plugins or anything complex. I am rendering 720p and using the animation codec.

It's really sad that it renders faster with multiprocessor support turned off and I still have use of my system. With it turned on my processors are barely used but since all the RAM is used my system is brought to its knees. I can't really do anything else.


Return to posts index

Theo Veltman
Re: Octomac Render Slows Down
on Oct 22, 2009 at 2:00:42 am

Sorry for not elaborating. What I'm doing is loading an instance of after effects and rendering frame 1-50 of my comp then loading another instance of after effects and rendering frame 51-100 then another with frame 101-150 e.t.c. I render to frames but you can render to movies if you like. Then compile them back together afterward. You can also work on another comp or project while you render in the background.
It all depends on what your comp is as to how much of the systems resources are used for each render. I've had some projects with heavy effects that only used 1.5gb of memory but 1050% of the cpu (i.e. 11 of the processors for one instance of after effects). Adobe aren't the only ones finding it hard to code for multiple processors at the moment, it's a problem everyone's facing right now along with the move to a 64bit software environment.


Return to posts index

Walter Soyka
Re: Octomac Render Slows Down
on Oct 22, 2009 at 3:04:51 am

I had a similar render issue on a MBP recently. My project was just a series of simple scales and crops on a very large image sequence, and after about 30 frames or so of speedy rendering, it ground to a halt.

I disabled the layer cache and set AE to purge every 20 frames during make movie. There's a secret menu in the preferences where you can adjust these—though this should be a last resort. Hold down the shift key, and keep it down. Click After Effects > Preferences > General. Continue to hold the Shift key, and click on the list of preferences. You should see a "Secret" item where you can make these changes.

If your renders were working perfectly, you would see a big performance hit for mucking with these settings; however, since they are not, it may help. Don't forget to reset them for your next project.

Walter Soyka, Principal
Keen Live, Inc.
Presentation, Motion Graphics & Widescreen Design
RenderBreak: A Blog on Innovation in Production



Return to posts index


Chris Wnuk
Re: Octomac Render Slows Down
on Mar 12, 2010 at 2:40:29 pm

Has anyone found a solution to this issue yet? This is causing me major headaches. I have tried all sorts of RAM and multiprocessing settings and the same thing still happens to me. I've also tried the secret preferences you recommended, but they didn't seem to make a difference...

It goes fine rendering the project on multiple cores pretty speedily until about 20 frames in, when all the "aeselflink" processes dump their RAM and drop to using 1.0% cpu time.

Any assistance is greatly appreciated.

Thanks!

-Chris

After Effects 9.02
8 Core Mac Pro
Snow Leopard 10.62
16 GB RAM


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]