ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Preview to ram slow to start

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Tim Stonesifer
Preview to ram slow to start
on Oct 20, 2009 at 6:02:30 pm

Lately, when doing a ram preview, my machine will quickly render the first couple of frames. Then, there is a delay of about 30 seconds, and it resumes rendering at the appropriate speed. This is a new system, but early on it didn't used to do this. I'm using an i7 with 12 gigs ram. Any thoughts on why the delay?


Return to posts index

Dave LaRonde
Re: Preview to ram slow to start
on Oct 20, 2009 at 6:38:22 pm

Could it be the kind of footage you're using? Read On:

Dave's Stock Answer #1:

If the footage you imported into AE is any kind of the following -- footage in an HDV acquisition codec, MPEG1, MPEG2, mp4, m2t, H.261 or H.264 -- you need to convert it to a different codec.

These kinds of footage use temporal, or interframe compression. They have keyframes at regular intervals, containing complete frame information. However, the frames in between do NOT have complete information. Interframe codecs toss out duplicated information.

In order to maintain peak rendering efficiency, AE needs complete information for each and every frame. But because these kinds of footage contain only partial information, AE freaks out, resulting in a wide variety of problems.


Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

Tim Stonesifer
Re: Preview to ram slow to start
on Oct 20, 2009 at 6:47:04 pm

Interesting. Two thoughts:

One, what's an ideal codec to use? Quicktime? I do often bring in m2v footage. Is there a transcoding program that's popular?

Second thought: I checked out a project that has no video in it and did a ram preview. The preview doesn't stall out for the 30 seconds that it does for other projects, but it does hang for a half second about 8-10 frames in. Obviously, that's not a big deal, but I thought it might give some more insight into what's going on.



Return to posts index


Dave LaRonde
Re: Preview to ram slow to start
on Oct 20, 2009 at 7:11:49 pm

Since I'm a Mac guy, you can use QT Pro to convert the footage to either QT's Animation codec or the PNG codec... not a PNG sequence, mind you but a movie compressed in the PNG codec. At best quality, both are lossless.

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

Ryan McAfee
Re: Preview to ram slow to start
on Oct 20, 2009 at 6:47:36 pm

Just a shot in the dark but maybe something is competing with AE. Since you said your comp is new maybe there are updates running in the background.

Ryan McAfee
Moon Community Access Television
http://www.MCA-TV.com


Return to posts index

Todd Kopriva
Re: Preview to ram slow to start
on Oct 20, 2009 at 7:08:03 pm

One possibility:

If you're being overly aggressive with the use of the Render Multiple Frames Simultaneously multiprocessing feature, starving some of the processes of RAM, then After Effects can take a little time to shut down a few of the processes so that it can keep going.

If you've only got 12GB of RAM, you probably shouldn't be using all of your processor cores in an 8-core system, but instead should leave a few for other applications.



---------------------------------------------------------------------------------------------------------
Todd Kopriva, Adobe Systems Incorporated
putting the 'T' back in 'RTFM' : After Effects Help on the Web
---------------------------------------------------------------------------------------------------------
If a page of After Effects Help answers your question, please consider rating it. If you have a tip, technique, or link to share---or if there is something that you'd like to see added or improved---please leave a comment.


Return to posts index


Tim Stonesifer
Re: Preview to ram slow to start
on Oct 20, 2009 at 7:33:07 pm

That's gotta be it. The settings only list 4 cores, but I limited AE to 3 cores and tweaked the ram settings. That seems to fix it. Looks like I'll futz around with that a bit more. Thanks for the ideas, guys!



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]