ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

How do I stop light showing through a layer?

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Maddy McAllan
How do I stop light showing through a layer?
on Oct 15, 2009 at 9:02:05 pm

I'm trying to create static lights in a corridor sequence and now I've placed all the lights I've noticed that the light is showing through the wall on the left. Also, in text portions in front of the lights in the corridor, the light spot shows through - even when material options are set to not accept light.

It's probably something really simple, but what am I doing wrong? Here's a screencap to help explain what I mean. http://i5.photobucket.com/albums/y164/hockey_bauer/Corridor.jpg

The light on the left is showing through the brick wall when I want it to only be visable beyond the wall at the end.

The lights were made using a spot light and Trapcode Lux.


Return to posts index

Dave LaRonde
Re: How do I stop light showing through a layer?
on Oct 15, 2009 at 9:24:33 pm

You're not trying to use Trapcode Lux, are you?

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

Maddy McAllan
Re: How do I stop light showing through a layer?
on Oct 15, 2009 at 9:27:42 pm

Yeah! Why? Is there a better option for what I need?


Return to posts index


Dave LaRonde
Re: How do I stop light showing through a layer?
on Oct 15, 2009 at 10:01:04 pm

Actually, I liked Lux when it was available to me, but you have to be careful when using it: it makes AE lights visible, and you might not want that in all cases. You'd have to go over the Lux tutorials to make sure you've got all the gotchas eliminated.

Your problem may also be due to not placing the lights in proper 3D space. Hey, it can happen.

You may be nesting a 3D comp inside the main 3D comp, and the x-y-z coordinates aren't what you think they are.

But a more fundamental problem comes with mixing 2D and 3D layers in a comp. Those 2D layers can really mess up a carefully-built 3D environment. Get rid of any 2D layers if you can, and turn them into 3D layers.

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

Maddy McAllan
Re: How do I stop light showing through a layer?
on Oct 15, 2009 at 10:04:23 pm

Every layer in the comp is 3D for this project. I may just have to switch Lux on and off and try that. If anyone knows a better, simpler option - I'm all ears!

Thanks in advance!


Return to posts index

Dave LaRonde
Re: How do I stop light showing through a layer?
on Oct 15, 2009 at 11:08:09 pm

Y'know, upon further recollection there may be a way to set Lux so all you see is the volumetric light and not the light itself. It's certainly worth looking into. Sadly, I can't look at its controls any more.

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]