ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Renders come out with a black background after keying with Keylight

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Christopher WilliamsRenders come out with a black background after keying with Keylight
by on Oct 9, 2009 at 5:30:31 pm

I have Adobe After Effects CS4 and i have been keying some HD footage with Key light 1.2. But when i render and drop my clips into Final Cut 7, it comes in with a black background. In Final Cut I have a white layer under my footage, which should show through my key, when I render out of after effects, I key check it in after effects and it works and I render it, with None compression - RGB + Alpha - Millions of Colors + with Audio. Anyone know why that black background is happening, and way i can fix it? Thanks!


Return to posts index

Andy GeorgeRe: Renders come out with a black background after keying with Keylight
by on Oct 9, 2009 at 6:31:43 pm

Christopher,

Sounds like your rendering it correctly.

Sometimes FCP misinterprets your footage with Alpha Channels. In FCP select the
clip and go to Modify>Alpha type>Straight.

-Andy


Return to posts index

Christopher WilliamsRe: Renders come out with a black background after keying with Keylight
by on Oct 9, 2009 at 7:11:32 pm

I changed to alpha to straight , but the black background is still there, Thanks Tho


Return to posts index


Dave LaRondeRe: Renders come out with a black background after keying with Keylight
by on Oct 9, 2009 at 7:30:44 pm

[Christopher Williams] " But when i render and drop my clips into Final Cut 7, it comes in with a black background. In Final Cut I have a white layer under my footage, which should show through my key...."

Why would you want to just key the footage? That's FCP-thinking. Try some AE thinking: why not just do the WHOLE SHOT in AE, background included? Heck, you're rendering anyway, so you might as well include the background, too.

Such a procedure frequently works to your advantage. For example, you can incorporate light wrap techniques to make the subject look more like it was actually in the foreground all the time. It's also easier to spot keying errors.

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

Christopher WilliamsRe: Renders come out with a black background after keying with Keylight
by on Oct 9, 2009 at 7:42:54 pm

I like to have the flexibility to scale and move my subjects freely from whatever my background is at the time. so if i did it all in AE the background will scale and move with my subjects ect.


Return to posts index

Gary HazenRe: Renders come out with a black background after keying with Keylight
by on Oct 9, 2009 at 8:45:00 pm

What does the matte look like in AE prior to rendering? Set the view to alpha only.


Return to posts index


Christopher WilliamsRe: Renders come out with a black background after keying with Keylight
by on Oct 9, 2009 at 8:51:43 pm

Yeah, my subjects are completely white and everything else is black


Return to posts index

Kevin CampRe: Renders come out with a black background after keying with Keylight
by on Oct 9, 2009 at 10:13:24 pm

what happens if you import the keyed footage back into ae. does ae see the key?

if so, try rendering a mov with another codec. i'd try losseless (rgba, millions+, straight) or png (quicktime png, not png sequence, same settings).

if neither of those work, i'd give an image sequence a try (tiff or png). apple recently release an update to quicktime, and it's possible that it broke something... it wouldn't be the first time.

one last thing (sorry, but i have to ask).... you don't happen to have a black solid in the comp...? if you hit the checker board button in the preview window, you do see checkers rather than black. sorry to ask the obvious, but sometimes it happens :)


Kevin Camp
Senior Designer
KCPQ, KMYQ & KRCW


Return to posts index

Joshua BurkeRe: Renders come out with a black background after keying with Keylight
by on Nov 2, 2009 at 7:20:03 pm

Hey
Hows it going?
I had the same exact problem you are having. After a lot of messing about I finally fixed the problem. I my render cue in after effects I used the same settings you did and got the same results. My solution came when I went to the arrow next to the output module in the render cue, clicking it brings up a list of presets, I selected Lossless with Alpha. For some reason it worked, I guess that there is some setting in that preset I didn't have set properly before, I haven't figured out what yet but right now I don't care... I can keep working!


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]