ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Precomp audio track won't export...

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Andrew Spirk
Precomp audio track won't export...
on Aug 26, 2009 at 7:12:10 am

I'm kind of pulling my hair out trying to figure this out.

I have a final comp that has an audio track nested in a precomp. I can ram preview and hear it fine, but when I add it to the render queue, everything I've tried to get it to render is not working.

No matter what I seem to do, the audio won't render out with the video.

Any ideas?


Return to posts index

Todd Kopriva
Re: Precomp audio track won't export...
on Aug 26, 2009 at 1:29:30 pm

Starting with the simple things...

You've checked Audio Output in the Output Module settings?

"Output modules and output module settings"
"Note: Before rendering, check the Audio Output settings in the Output Module Settings dialog box to ensure that they are correct. To render audio, Audio Output must be selected."

---------------------------------------------------------------------------------------------------------
Todd Kopriva, Adobe Systems Incorporated
putting the 'T' back in 'RTFM' : After Effects Help on the Web
---------------------------------------------------------------------------------------------------------
If a page of After Effects Help answers your question, please consider rating it. If you have a tip, technique, or link to share---or if there is something that you'd like to see added or improved---please leave a comment.


Return to posts index

Andrew Spirk
Re: Precomp audio track won't export...
on Aug 26, 2009 at 7:34:19 pm

Yes, indeed I have. I discovered my problem, which was quite odd. In my precomp, the audio came from a guide layer, which played fine, but for whatever reason didn't render out. Making it a normal layer and invisible, while checking that the audio is still passed through, works.

On another note, why the change with the custom camera not showing 2d layers with 3d layers in cs4?


Return to posts index


Todd Kopriva
Re: Precomp audio track won't export...
on Aug 26, 2009 at 7:51:18 pm

> I discovered my problem, which was quite odd. In my precomp, the audio came from a guide layer, which played fine, but for whatever reason didn't render out.


The whole point of guide layers is that they are layers used for reference but not rendered and exported for final output, so it's not surprising to me that audio on a guide layer wouldn't be included in final output. You can, however, choose to include guide layers in final output. Just choose Current Settings from the Guide Layers menu in the Render Settings dialog box. (See "Guide layers".)


> On another note, why the change with the custom camera not showing 2d layers with 3d layers in cs4?


Because it doesn't make sense to show 2D layers in a strictly 3D view. Sure, it makes sense to show 2D layers in a camera view that is actually rendered (like the active camera view), but that is showing you a 2D composite of a 3D scene.

If you'd like the option to show 2D layers in orthographic and working 3D views, you can certainly make a feature request. Be sure to say exactly how and why you'd use this, though---because I know the engineer who's going to be reading that request, and my previous paragraph is channeling him.

---------------------------------------------------------------------------------------------------------
Todd Kopriva, Adobe Systems Incorporated
putting the 'T' back in 'RTFM' : After Effects Help on the Web
---------------------------------------------------------------------------------------------------------
If a page of After Effects Help answers your question, please consider rating it. If you have a tip, technique, or link to share---or if there is something that you'd like to see added or improved---please leave a comment.


Return to posts index

Andrew Spirk
Re: Precomp audio track won't export...
on Aug 26, 2009 at 8:04:44 pm

Thanks for the quick response Todd. It was one of those problems you get when you have a bunch of precomp layers piled on top of each other, sometimes things get lost in the mess.

I'll toss Adobe a feature request, but it's always been a part of cs3 and previous versions of AE. The reasoning being to use the 2d layer as a background within the orthographic view. There are certainly better ways of doing it, as I've found, but I just liked being able to create a comp, throw some elements in, and switch to the custom view of my choosing and begin contruction of my scene in a view that already has depth to it.

At any rate, thanks for the quick answers!


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]