ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Problems

COW Forums : Video Copilot

VIEW ALL   •   PRINT
Nicholas Toth
Problems
on Oct 14, 2008 at 5:28:01 pm

SO

2 Separate machines, 2 separate clients. One common big problem. (going for the dramatic intro!)

These are both designated AE/FCP boxes, one is an Octo 3.0 w/4 gigs of ram and one is an Octo 2.8 w/32 gigs of ram. Both have the SAME problem, when multiprocessing is enabled, things freeze RIGHT before a render completes, so batch rendering is impossible. Upon loading a terminal prompt, and going to my table of processes, there are MANY more than 8 instances of AE running (Perhaps 32 or so?), and it still runs when AE has crashed and quit.


Is anyone else running into this? Is it time to bring in a shotgun? Or take them skydiving out the window? It makes a 3 minute task take half an hour with restarting/resetting AE.




Return to posts index

Nicholas Toth
Re: Problems
on Oct 14, 2008 at 5:39:55 pm

turned off multi-processing and things are working --- but at 1/8th speed.




Nicholas Toth
Freelance Animator
nicholastoth.com


Return to posts index

Kevin Camp
Re: Problems
on Oct 14, 2008 at 7:18:25 pm

i have had aeseflink processes remain open after ae crashes, then when ae restarts, it starts up a new set of selflink processes. sometimes some of the original processes are still processing and it causes all kinds of issues with ae. that may be what you're seeing.

reboot to clear things out. then open the activity monitor (applications>utilities>activity monitor). fire up that ae project and watch the activity monitor to see how many aeselflink processes open up.

if it is more than it should be, then something is really wrong.

Kevin Camp
Senior Designer
KCPQ, KMYQ & KRCW


Return to posts index


Nicholas Toth
Re: Problems
on Oct 14, 2008 at 9:43:33 pm

Kevin,
Thanks for the suggestion! The only thing is re-booting the same amount that I'm crashing is not exactly...well...practical. (this thing is crapping its pants quite frequently....but I got what I have to get done for now and I'm swimming in FCP)


One of our AE guys at a place I'm working at is an awesome scripter, he figured out a terminal prompt command to force quit the ae-links, which I think are the cause of the crashes. Gotta really throw some hard stuff at AE though, to intentionally crash it then try it out. Ditching my prefs helped a little bit, but its still quite buggy.



Is anyone else out there who is running OS X having this problem? We have Zaxwerks(full)/Nucleo(pro2)/Coremelt/NoiseIndustries/Looksuite/Twitch/Trapcode(entire) if any of them matter, running in AE CS3 8.0.1. Glintworks and OpenGL haven't been getting a long here and there, but I don't see that as a render instance problem...






Nicholas Toth
Freelance Animator
nicholastoth.com


Return to posts index

Kevin Camp
Re: Problems
on Oct 14, 2008 at 10:54:38 pm

in addition to terminal, you can force quit the selflink processes in the activity monitor, just select them and hit the red stop sign icon... you would probably want to do that after each ae crash to make sure you are canceling the right ones.

if trashing the prefs helped a little, you might try trashing the whole folder that contains it (called 8.0 for cs3). ae will rebuild the whole directory and all the files on the next go.

i'm curious what the terminal command for force quit the aeselflink apps? is it one command for all of them?

Kevin Camp
Senior Designer
KCPQ, KMYQ & KRCW


Return to posts index

Nicholas Toth
Re: Problems
on Oct 15, 2008 at 4:19:45 pm

I think he said that what we do is,
Load the running processes, sort by a certain type, then kill that type. I've done it with the activity monitor in the past, but if we can automate this, it would be great.


I have to hound him today, because he wrote it down for me and I can't read it. I'll get back to you.

Nicholas Toth
Freelance Animator
nicholastoth.com


Return to posts index


Kevin Camp
Re: Problems
on Oct 15, 2008 at 7:14:27 pm

i saw that you're running 8.0.1, i think the 8.0.2 update addressed an issue with 8-core machines and multiprocessing... it might be worth the time to update.

although, if you are using nucleo pro for multiprocessing, the update may not address that issue, but you could try with nucleo on/ae multiprocessing off and then the reverse to see if that helps.

another thing you might try is limiting the number of cores available to ae's multiprocessing, using th preference hack. open the preference in text edit, find 'mp' (use 'whole word', hit find next a couple times until you get the the max cores part), set the max cores from '0' to '4' (or anything less than 8), see if that has any effect.

an easier way to change that setting, with a few added options, is with cool little gui script from aescripts.com, called throttle, if you have time to check that out.

Kevin Camp
Senior Designer
KCPQ, KMYQ & KRCW


Return to posts index

VIEW ALL   •   PRINT
© 2020 CreativeCOW.net All Rights Reserved
[TOP]