ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Blank bar appearing next to layer when position keyframes added

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Chelsey Meyer
Blank bar appearing next to layer when position keyframes added
on Dec 4, 2018 at 3:28:16 pm

I'm assuming this must be an error on my part that has something to do with the settings.

In this composition, a white square (with the triangle on it) comes across the screen from the right side, revealing a green background gradient. The problem? Whenever I add position keyframes to the white square, pixels of blank space appear to its right on top of the gradient once it stops. The blank pixels are not there as it moves across the screen. If I make the white square invisible, it's clear that the blank pixels are not a part of the gradient. If I place any other large solid behind the white square, the blank pixels are still there.


Additionally, the pixels stay blank in exports. I just upgraded After Effects, but the problem was happening in CC 2018 as well.

The problem:


Not happening during movement:


Settings:


Return to posts index

Mark Doctor
Re: Blank bar appearing next to layer when position keyframes added
on Dec 4, 2018 at 5:36:33 pm
Last Edited By Mark Doctor on Dec 4, 2018 at 5:39:21 pm

Try turning off the drop shadow and see what happens. Because I don't see transparent pixels but a small gradient.

Greets Mark


Return to posts index

Chelsey Meyer
Re: Blank bar appearing next to layer when position keyframes added
on Dec 4, 2018 at 6:10:00 pm

Looks like I figured out the problem. Thanks Mark, it was in the Drop Shadow. By changing the Blending Mode to Stencil Alpha, I'm able to remove the blank space and keep the shadow.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 CreativeCOW.net All Rights Reserved
[TOP]