ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Effects messed up by camera movement

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Joseph Baka
Effects messed up by camera movement
on Jun 4, 2018 at 7:19:23 am

Hi! I have the following problem:

I have an animation scene with a camera layer, which does a simple panning to the right. I made all of my 2D layers to 3D in order to be recognised by the camera. Some of these layers contain effects like Light Sweep, Liquify and so on. But when the camera moves these effects somehow "follow the camera" if it makes sense. For example: I added a Light Sweep to a shape layer, but during the pan it goes darker.

I know it can be fixed with keyframing the effect, but I'm pretty sure there is a faster and easier way to solve this.


Return to posts index

Cassius Marques
Re: Effects messed up by camera movement
on Jun 4, 2018 at 1:32:17 pm

Since you're applying an effect to a shape layer, the effect renders after the layer is rasterized. The dimensions of your layer are the dimensions of your composition. It seems to move because the layer is beeing rasterized again in another part of its canvas, without it actually having any of its transformations change. To solve this you'd have to precompose the shape layers and anything else thats being continously rasterized. Either that or animate the sweeps.

Pro Tip: You can add an expression to the sweep's center, something like:

a=thisLayer;
value+(a.toComp(a.anchorPoint));

After you set the sweep's position (again, because it will change place) it will stay put as the camera pans left/rigth/up/down.

Cassius Marques
http://www.zapfilmes.com


Return to posts index

Joseph Baka
Re: Effects messed up by camera movement
on Jun 4, 2018 at 2:05:54 pm

Thank you for the answer, it helped a lot! Previously I tried to solve it with precomposing the layers, but apperently I messed up the workflow. I followed your instructions, and here is how I made it work: Create shape layer -> Check 3D layer -> Precompose -> Check 3D on precomp -> Add effect(s)-> Uncheck Collapse transformations -> Works like a charm.

I will try that expression too, because I like to work directly with shapes instead of precomposing everything. Thanks again, saved me a lot of time.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 CreativeCOW.net All Rights Reserved
[TOP]