ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

AE displays wrong frame at cut points

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Adam Rosenberg
AE displays wrong frame at cut points
on Jan 5, 2017 at 4:46:04 am

I imported a Premiere sequence into After Effects so each shot/cut should match my edit exactly. Yet oftentimes, if I place my playhead at a cut, instead of showing the first frame of the clip I'm on it will display the last frame of the previous clip. Sometimes it will even display nothing so that there is a frame of black at the cut. This can sometimes be fixed if I extend the second clip back a frame underneath the first clip, but sometimes this doesn't work. This seems to happen more frequently if a clip is time remapped/stretched.

Sometimes there is nothing that can done to fix it. Even if I delete the first clip completely, the last frame of that clip will still display where the first frame of the second clip should be! Even though it's completely gone from the timeline! When I render the glitch shows up too, so it's not an illusion.

I've experienced this many times in the past, and it's super annoying. Especially when I've "locked" an edit in Premiere and then my cuts sporadically move a frame or two in AE.


Return to posts index

Tero Ahlfors
Re: AE displays wrong frame at cut points
on Jan 5, 2017 at 5:02:18 am

The AE out points are inclusive like in Premiere. If you zoom in the timeline you'll see a small highlighted line after the playhead. That is the frame you are looking at.


Return to posts index

Adam Rosenberg
Re: AE displays wrong frame at cut points
on Jan 5, 2017 at 5:07:52 am

I am aware that out points are inclusive. If I zoom in as far as I can the playhead is exactly on the cut. So it should show the first frame of the second clip. And that still wouldn't explain how AE displays the last frame of the first clip even when I delete the first clip.


Return to posts index


Dave LaRonde
Re: AE displays wrong frame at cut points
on Jan 5, 2017 at 2:46:58 pm

In cases like this, I always look for possibilities of a frame rate mismatch... in your case, originating in PP.

Dave LaRonde
Promotion Producer
KGAN (CBS) & KFXA (Fox) Cedar Rapids, IA


Return to posts index

Blaise Douros
Re: AE displays wrong frame at cut points
on Jan 5, 2017 at 5:19:50 pm

Have you tried purging your media cache? You might be experiencing a glitch where the cached frame is being displayed, and not the actual footage in the timeline.


Return to posts index

Adam Rosenberg
Re: AE displays wrong frame at cut points
on Jan 5, 2017 at 5:25:52 pm

Thanks Blaise. Yeah I tried that too. Still doesn't work.


Return to posts index


Blaise Douros
Re: AE displays wrong frame at cut points
on Jan 5, 2017 at 8:09:08 pm

Hmm. This is a weird suggestion, but try changing your Preview resolution (from Full to 1/2, for example). I had a crazy weirdo issue this week with a sequence where I would animate a mask, but the changes wouldn't show up on the Previews unless I forced AE to re-render at a different rez by changing the preview rez; and the REALLY weird part was that if I changed it back to a rez that I had used already, it would revert to whatever version of the clip had been showing when I last used that resolution. So I had basically four chances (one for each resolution) at previewing any change before I was hosed.


Return to posts index

Adam Rosenberg
Re: AE displays wrong frame at cut points
on Jan 6, 2017 at 6:20:03 am

Tried that too. No dice.


Return to posts index

Roei Tzoref
Re: AE displays wrong frame at cut points
on Jan 7, 2017 at 10:59:04 am

Please show us full screenshots Ae vs Premiere. Show the Same timecode and different result. Make sure the whole U.I is visible. You can drag and drop here or copy paste from clipboard.

Roei Tzoref
After Effects Artist & Instructor
♫ Ae Blues Tutorials


Return to posts index


Adam Rosenberg
Re: AE displays wrong frame at cut points
on Jan 7, 2017 at 11:51:06 pm

Sure thing. You can see the same time code on both, and zoomed in on the timeline all the way. It's a shot reverse shot. You can see in Premiere that the first shot is of the female, and the second is of the male. Yet in AE when on the first frame of the second shot, it's still showing the female.




Return to posts index

Roei Tzoref
Re: AE displays wrong frame at cut points
on Jan 8, 2017 at 12:49:01 am

very strange. what happens one frame after? does it then show the next layer?

you should try to isolate the problem as much as you can. only one cut, 2 layers with speed changes/without - see where it breaks. is the pixel motion related? does this happen on 2015.3? move layer 23 (0438) above layer 22 (0437) ? is it o.k now? btw it is better to work staircase up and not down in a compositing app so if you want just select all the layers from bottom to top and cut and paste, and it will paste them in reverse order.

Roei Tzoref
After Effects Artist & Instructor
♫ Ae Blues Tutorials


Return to posts index

Adam Rosenberg
Re: AE displays wrong frame at cut points
on Jan 8, 2017 at 2:08:09 am

I tried everything you mentioned and more. Nothing worked until I finally found a crazy weird solution:

First I duplicated my entire comp and deleted everything except for that second clip with the incorrect frame. Even isolated within this new comp, the clip still was still stuck with that single frame showing the girl. The frames before and after were correct. Then I dropped a black solid beneath the clip and BOOM! The frame was now correct. So I dropped this new comp back into my original... and the frame was still wrong! It wasn't until I deleted the original bad clip below it that the frame finally displayed correctly in my original comp.

I can't explain how or why any of this happened. It seems like something was being cached incorrectly, but I cleaned out my cache multiple times when trying various solutions and it never helped.


Return to posts index


Adam Rosenberg
Re: AE displays wrong frame at cut points
on Jan 10, 2017 at 3:49:57 am

Well upon re-opening the project, the problem is back. Repeating the process that worked before no longer works. Not sure what else to do besides rendering out the entire composition, then manually editing in the correct frame and re-rendering.


Return to posts index

Andrew Jehan
Re: AE displays wrong frame at cut points
on Mar 15, 2017 at 3:08:09 am

I have been having this exact same problem and it is driving me absolutely bonkers. Just like with you, it is happening in a composition that I brought in to After Effects from a Premiere sequence.

After Effects is clearly acting bizarrely in relation to these clips. Nothing I do can eliminate the problem. When I add a new adjustment layer above the affected frame(s), it changes which frame is wrong, but the problem remains.

I am just about ready to encode out the Premiere sequence and import the file into After Effects.


Return to posts index

Adam Rosenberg
Re: AE displays wrong frame at cut points
on Mar 15, 2017 at 3:59:44 pm

Yep. I never figured out a way around it. I think rendering out a video file from Premiere then importing into AE is the only for sure way to make it stop.


Return to posts index


David Busse
Re: AE displays wrong frame at cut points
on Mar 15, 2017 at 9:02:49 pm

I'm having this exact same problem. Only solution I've found aresimilarly tedious workarounds that stop working at random.

However, this seems to be the best one so far:
Cut the clip that AE is displaying wrong then paste it somewhere else, change a keyframe by a fraction of a parameter (so that the cache won't try to go back to what it was before) then slide the clip back into place.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]