ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Nested Comps don't cast shadows in Main Comp

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
wilhelm Hagberg
Nested Comps don't cast shadows in Main Comp
on Dec 7, 2016 at 5:18:51 pm

Hello,
I have a little problem, can't figure out what I'm doing wrong.

In my Master Comp i have a few pre comps and a Spotlight. I animate the Pre-Comps in 3d space and I want the Pre- Comps to cast shadows on each other. The light itself works but for some reason the shadows don't.

I have set the light to "Cast Shadows". Inside the pre comps I have set the materials to accept and cast shadows.
As you can see in my screen shot, i've used "alpha track matte" to cut ring shapes out of the original photo. Is this the problem or something else?
Best- Wilhelm





Return to posts index

Cassius Marques
Re: Nested Comps don't cast shadows in Main Comp
on Dec 7, 2016 at 6:01:55 pm

[wilhelm Hagberg] " Is this the problem or something else?"
Probably. You should duplicate your mattes and set their material options to: cast shadow: only.

Cassius Marques
http://www.zapfilmes.com


Return to posts index

wilhelm Hagberg
Re: Nested Comps don't cast shadows in Main Comp
on Dec 9, 2016 at 10:48:02 am

Thanks, I'll try that. I don't see a "cast shadow : only" option however?

- Wilhelm



Return to posts index


wilhelm Hagberg
Re: Nested Comps don't cast shadows in Main Comp
on Dec 9, 2016 at 11:21:18 am

Thank you Cassius! I found the "cast shadow: only" option – and I'm sure that will be very useful in the future! After fiddling around with my project for a while I realised this wasn't the problem however. Early on I had played with "Layer styles" in the Main Comp. Although they were all turned off it seems like they affected to layers ability to accept shadows. I had to totally exterminate them (layer-layer styles-remove all) and now the project functions as expected.

Best-
Wilhelm



Return to posts index

Roei Tzoref
Re: Nested Comps don't cast shadows in Main Comp
on Dec 9, 2016 at 4:23:32 pm
Last Edited By Roei Tzoref on Dec 9, 2016 at 4:23:59 pm

[wilhelm Hagberg] " Although they were all turned off it seems like they affected to layers ability to accept shadows. I had to totally exterminate them (layer-layer styles-remove all) and now the project functions as expected.
"


layer style will break Ae's 3d interactivity . even if you had no checkbox on the layer style itself, you actually have to remove the master checkbox for them not to affect anything (or remove them completely)

this is from the help files about layer styles:
https://helpx.adobe.com/after-effects/using/blending-modes-layer-styles.htm...

You can apply a layer style to a 3D layer, but a layer with a layer style can’t intersect with other 3D layers or interact with other 3D layers for casting and receiving shadows. 3D layers on either side of a layer with a layer style can’t intersect one another or cast shadows on one another.


also from the help files about 3d layers:
https://helpx.adobe.com/after-effects/using/3d-layers.html#3d_layer_interac...

"Just like 2D layers, other types of layers also prevent 3D layers on either side from intersecting or casting shadows on one another:

An adjustment layer

A 3D layer with a layer style applied

A 3D precomposition layer to which an effect, closed mask (with mask mode other than None), or track matte has been applied

A 3D precomposition layer without collapsed transformations"

Roei Tzoref
After Effects Artist & Instructor
♫ Ae Blues Tutorials


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]