ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Missing effect in the main composition (noob question)

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
André HelalMissing effect in the main composition (noob question)
by on Oct 4, 2016 at 4:08:03 am

Hello!
I added an effect within a pre-composition and functions normally. But when I go to the main composition (which has some pre-compositions) the effect simply does not appear in that scene.

Does anyone know what the problem is?
Thank you very much!


Return to posts index

Tudor "Ted" JelescuRe: Missing effect in the main composition (noob question)
by on Oct 4, 2016 at 11:01:55 am

What effect are you referring to?
Can you post screen grabs of your Precomp and main comp Timeline

Tudor "Ted" Jelescu
Senior VFX Artist


Return to posts index

André HelalRe: Missing effect in the main composition (noob question)
by on Oct 4, 2016 at 4:45:06 pm

It is the "Light Sweep" effect.

The pre-composition:


The main composition:


Return to posts index


Roei TzorefRe: Missing effect in the main composition (noob question)
by on Oct 5, 2016 at 4:52:30 am

Please show screenshots of the exact same frame in precomp vs mastercomp and show the whole ae interface. We need to see all the information.

Roei Tzoref
After Effects Artist & Instructor
♫ Ae Blues Tutorials


Return to posts index

Dave LaRondeRe: Missing effect in the main composition (noob question)
by on Oct 4, 2016 at 8:14:52 pm

You have the effect applied to a single layer in the precomposition. You won't see that effect in the main composition.

If you want the effect on just one layer, you need to make adjustments in the precomp.
If you want the effect to apply to the entire precomp, apply the effect to the precomp layer in the main comp, and delete the effect on the layer in the precomp.

Dave LaRonde
Promotion Producer
KGAN (CBS) & KFXA (Fox) Cedar Rapids, IA


Return to posts index

André HelalRe: Missing effect in the main composition (noob question)
by on Oct 4, 2016 at 11:30:15 pm

I want the effect on just one layer. What kind of adjustments do I have to make in the precomp? Sorry, I don't get it.


Return to posts index


André HelalRe: Missing effect in the main composition (noob question)
by on Oct 4, 2016 at 11:59:55 pm

Now I noticed that when I deselect the "rasterize layer" , the effect appears... But I can't do this because it will destroy the quality of the video! ?



Return to posts index

Thomas FrenkelRe: Missing effect in the main composition (noob question)
by on Oct 5, 2016 at 3:34:17 pm

A screenshot would help alot. I guess you have some sort of transformation in the main composition, which is why you have to keep the main comp vectorized (with the switch that you mentioned). Usually you have to take this transformation to the Pre-Comp and do it there or keep everything in a single comp. But it depends alot on what you're trying to achieve. Maybe you can even take your effect to the main comp and add it there.

(On which monitor did you take those AE-Screenshots? Or can you scale the UI of AE? I always wondered...)


Return to posts index

André HelalRe: Missing effect in the main composition (noob question)
by on Oct 5, 2016 at 11:23:33 pm

Yes, I animated the position and the scale in the main composition. I think I will have to try to recreate the effect in the main composition... But I wanted to know why this happens, for my next projects. Thank you for explaining to me!

I work on a 5k iMac.

(Sorry for bad english, it is not my native language).


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]