ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

AE-Premiere dynamic link not working unless both versions are CC2015.3?

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Michael Trenton
AE-Premiere dynamic link not working unless both versions are CC2015.3?
on Jul 28, 2016 at 5:00:20 pm

Hi there,
After running CC2014 of After Effects, Premiere, Audition, Media Encoder and Speedgrade for about a year I upgraded everything except After Effects to CC2015 a few months back.
A couple of weeks ago I needed to have dynamic link between Premiere and AE to do some effects work so I decided to also upgrade After Effects (Adobe CC automatically updating AE to CC2015.3 and also updating Media Encoder), but the 'REPLACE WITH AFTER EFFECTS COMPOSITION' dialogue is still greyed out.
So does this mean I will have to also upgrade Premiere from CC2015 to CC2015.3 in order to make this option available to me again?


Return to posts index

Walter Soyka
Re: AE-Premiere dynamic link not working unless both versions are CC2015.3?
on Jul 28, 2016 at 5:06:29 pm

Yes, Dynamic Link only works between applications with the same version.

Walter Soyka
Designer & Mad Scientist at Keen Live [link]
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
@keenlive [twitter]   |   RenderBreak [blog]   |   Profile [LinkedIn]


Return to posts index

Dave LaRonde
Re: AE-Premiere dynamic link not working unless both versions are CC2015.3?
on Jul 28, 2016 at 5:07:24 pm

Not necessarily. You could do your AE voodoo in CC 2015 (although if you don't HAVE to, I wouldn't), open the project file in AE CC2014, Save the file, and use CC2014 for the dynamic link.

Or as hinted at above, just work in AE CC 2014.

But to answer your question, the AE & PP version numbers have to match.

Dave LaRonde
Promotion Producer
KGAN (CBS) & KFXA (Fox) Cedar Rapids, IA


Return to posts index


Walter Soyka
Re: AE-Premiere dynamic link not working unless both versions are CC2015.3?
on Jul 28, 2016 at 5:15:59 pm

[Dave LaRonde] "You could do your AE voodoo in CC 2015 (although if you don't HAVE to, I wouldn't)... Or as hinted at above, just work in AE CC 2014."

Are you running 2015.x at your stations now?

I did some work on Ae CC 2014 last week -- I was using it to render (multiprocessing!) and decided to make some adjustments right on the spot -- and I was really stunned at how pokey it was compared with Ae CC 2015.3. There are real, noticeable improvements in 2015. I feel that in our workflow, going back to CC 2014 for day-to-day work would be a major step backwards. Ae CC 2015 certainly has its share of issues, but for us, it's worth the tradeoff.

Walter Soyka
Designer & Mad Scientist at Keen Live [link]
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
@keenlive [twitter]   |   RenderBreak [blog]   |   Profile [LinkedIn]


Return to posts index

Dave LaRonde
Re: AE-Premiere dynamic link not working unless both versions are CC2015.3?
on Jul 28, 2016 at 5:45:32 pm
Last Edited By Dave LaRonde on Jul 28, 2016 at 5:58:44 pm

[Walter Soyka] "Are you running 2015.x at your stations now?"

Some are. Not me -- the home office sends out fully-installed & double-checked replacement hard drives for some edit workstations because they know the precise mix of OS, hardware & applications being run on them. Swap out the system drive, turn on the machine and you're upgraded.

So I'm on Adobe CC 2012 and Avid MC6. Hey, you work with what you've got. At least I don't have software woes.

And because our art guy, who sits 8 feet away from me, got a brand-new Windows box (the home office is phasing out Macs), he runs CC 2015. Go figure.

Dave LaRonde
Promotion Producer
KGAN (CBS) & KFXA (Fox) Cedar Rapids, IA


Return to posts index

Michael Trenton
Re: AE-Premiere dynamic link not working unless both versions are CC2015.3?
on Jul 28, 2016 at 5:24:22 pm

Thanks for your replies. It surprised me at first because I had hoped dynamic link would work as long as the software were all the same 'big' version (CC2014, CC2015 etc) and not that I'd lose dynamic link over differences in incremental versions numbers. That's a bit annoying I guess (particularly since I've heard rumours that 'direct link to Speedgrade' has been removed in Premiere CC2015.3).
Dynamic link to Media Encoder still works both from Premiere CC2015 and AE CC2015.3 though so could it really be so hard for Adobe to keep dynamic link working between incremental versions?

I'll guess I might as well upgrade all the rest of my Adobe software like Audition to CC2015.3 as well then. I reckon there is no hope that Adobe will release a Speedgrade CC2015.3 so I might as well start using DaVinci Resolve for colour grading instead.


Return to posts index


Walter Soyka
Re: AE-Premiere dynamic link not working unless both versions are CC2015.3?
on Jul 28, 2016 at 5:26:50 pm

[Michael Trenton] "I'll guess I might as well upgrade all the rest of my Adobe software like Audition to CC2015.3 as well then. I reckon there is no hope that Adobe will release a Speedgrade CC2015.3 so I might as well start using DaVinci Resolve for colour grading instead."

Ae CC 2015.3 is a separate install. You can still have Ae CC 2015 installed side-by-side if you wish.

Adobe has made some big changes to color in Premiere with the updated Lumetri Color Panel. You can do a lot of color directly in editorial now, but you're right on that it's no SpeedGrade or Resolve.

Walter Soyka
Designer & Mad Scientist at Keen Live [link]
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
@keenlive [twitter]   |   RenderBreak [blog]   |   Profile [LinkedIn]


Return to posts index

Michael Trenton
Re: AE-Premiere dynamic link not working unless both versions are CC2015.3?
on Jul 28, 2016 at 5:39:51 pm

[Walter Soyka] "Ae CC 2015.3 is a separate install. You can still have Ae CC 2015 installed side-by-side if you wish.

Adobe has made some big changes to color in Premiere with the updated Lumetri Color Panel. You can do a lot of color directly in editorial now, but you're right on that it's no SpeedGrade or Resolve."


Thanks. I already have AE CC2015.3 installed so it's Premiere that I'll need to upgrade from CC2015 to CC2015.3 in order to make dynamic link work between them.
But I guess I could keep Premiere CC2015 installed so that I still have a version of Premiere with direct link to Speedgrade? It's not gonna potentially mess anything up having multiple versions of Premiere installed is right?

Yes, I've heard the Lumetri panel have had some upgrades so I'm excited to test that out when I upgrade to 2015.3. I was really hoping Adobe would absorb all of Speedgrade's functionality and level of control into Premiere before they decided to ditch Speedgrade though. That's a huge dissappointment on Adobe's part in my book.


Return to posts index

Walter Soyka
Re: AE-Premiere dynamic link not working unless both versions are CC2015.3?
on Jul 28, 2016 at 5:43:17 pm

[Michael Trenton] "Thanks. I already have AE CC2015.3 installed so it's Premiere that I'll need to upgrade from CC2015 to CC2015.3 in order to make dynamic link work between them."

I think that if you kept Premiere CC 2015 and re-installed Ae CC 2015, you could use it to handle the setup and rendering for your dynamic link projects (even if you ultimately choose to do most of the work in Ae CC 2015.3).


[Michael Trenton] "It's not gonna potentially mess anything up having multiple versions of Premiere installed is right?"

I have every major release of Ae/Pr installed on my workstation going back to CS6. It all works fine.


[Michael Trenton] "Yes, I've heard the Lumetri panel have had some upgrades so I'm excited to test that out when I upgrade to 2015.3. I was really hoping Adobe would absorb all of Speedgrade's functionality and level of control into Premiere before they decided to ditch Speedgrade though. That's a huge dissappointment on Adobe's part in my book."

I hear you.

Walter Soyka
Designer & Mad Scientist at Keen Live [link]
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
@keenlive [twitter]   |   RenderBreak [blog]   |   Profile [LinkedIn]


Return to posts index


Michael Trenton
Re: AE-Premiere dynamic link not working unless both versions are CC2015.3?
on Jul 28, 2016 at 6:41:35 pm

[Walter Soyka] "I think that if you kept Premiere CC 2015 and re-installed Ae CC 2015, you could use it to handle the setup and rendering for your dynamic link projects (even if you ultimately choose to do most of the work in Ae CC 2015.3)."

Yes I guess that's certainly an option. I may consider this although now I'm a bit curious to check out version 2015.3 of Premiere. Though I'm not really sure how to install older versions of Premiere anyway now that the Creative Cloud application have automated the upgrading process. Is there even an option in the Creative Cloud app to install older versions of the applications?

[Dave LaRonde] "Just a reminder -- don't let the new install delete your existing suites of applications! You have to tell the installer, "No, I don't want to uninstall the old ones.""

Thanks. I'll be sure not to delete my previously installed programs.


Return to posts index

Walter Soyka
Re: AE-Premiere dynamic link not working unless both versions are CC2015.3?
on Jul 28, 2016 at 6:49:47 pm

[Michael Trenton] "Is there even an option in the Creative Cloud app to install older versions of the applications?"

Yup:

https://helpx.adobe.com/creative-cloud/help/download-install-app.html#topic...

Walter Soyka
Designer & Mad Scientist at Keen Live [link]
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
@keenlive [twitter]   |   RenderBreak [blog]   |   Profile [LinkedIn]


Return to posts index

Michael Trenton
Re: AE-Premiere dynamic link not working unless both versions are CC2015.3?
on Jul 28, 2016 at 7:13:57 pm

[Walter Soyka] "Yup:

https://helpx.adobe.com/creative-cloud/help/download-install-app.html#topic....."


That's awesome! Thanks a lot!


Return to posts index


Dave LaRonde
Re: AE-Premiere dynamic link not working unless both versions are CC2015.3?
on Jul 28, 2016 at 5:49:28 pm

[Michael Trenton] "I already have AE CC2015.3 installed so it's Premiere that I'll need to upgrade from CC2015 to CC2015.3 in order to make dynamic link work between them."

Just a reminder -- don't let the new install delete your existing suites of applications! You have to tell the installer, "No, I don't want to uninstall the old ones."

Adobe: always thinking in the users' best interests.....

Dave LaRonde
Promotion Producer
KGAN (CBS) & KFXA (Fox) Cedar Rapids, IA


Return to posts index

Roei Tzoref
Re: AE-Premiere dynamic link not working unless both versions are CC2015.3?
on Oct 14, 2016 at 1:12:01 am

[Dave LaRonde] "Just a reminder -- don't let the new install delete your existing suites of applications! You have to tell the installer, "No, I don't want to uninstall the old ones."

Adobe: always thinking in the users' best interests.....
"


this is not accurate. the whole reason they put this "remove old versions" in the first place was because of user feedback
http://blogs.adobe.com/adobecare/2015/06/15/creative-cloud-delivering-more-...

so we only have ourselves to blame here.

and another thing, as designers, editors and others that are supposed to be used to reading what's right in front of them, you would think we could read the fine print that says it will remove the old versions. we dismiss it because we are used to clicking o.k on everything. our fault x2.


if anything, we need Adobe to help us not be so lazy and give us something like this


Roei Tzoref
After Effects Artist & Instructor
♫ Ae Blues Tutorials


Return to posts index

Tim Chan
Re: AE-Premiere dynamic link not working unless both versions are CC2015.3?
on Oct 14, 2016 at 12:39:55 am

Hey,

I started to have this issue with dynamic link not working after I upgraded Premiere Pro and Adobe After Effects a few days ago. Before it worked totally fine.

After browsing the internet for hours it seems like some were right with this suggestion:

You have to have the exact same version for Premiere Pro and After Effects in order to use dynamic link. I just used Creative Cloud and downloaded CC 15.3 FOR BOTH programs and now it works so smooth.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]