ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

AI to AE converting to shape layers - creating weird additional shapes

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Kiril Parushev
AI to AE converting to shape layers - creating weird additional shapes
on Oct 14, 2015 at 12:46:15 pm

Hello, all.

After a thorough search and no solution, I decided to ask here.

So this happens:

I create some shapes in illustrator, I release everything to separate layers, save and go into after effects.
I import the ai file as a composition with retained layer sizes. Up to here everything seems to be perfect.

I need to animate some of the shapes, though, so I convert the layers to shapes.
Some of the layers create additional paths in groups which did not exist in AI. The additional paths are always as big as the entire composition. So, if the top layer creates such an additional path I can't directly select anything beneath it. The layer contains both the original shape I created plus the additional rectangular shape which encompasses the entire composition size.

I can, of course, go and manually delete each additional group in all the layers that contain it, but this seems weird to me. I must be missing something here.

Before the conversion to vector I can freely select each shape, as the size is retained. After I convert, I can no longer do it. I have to search for the layer I need manually in the layer stack.

i hope you guys will have an advice for me.

Thanks.


Return to posts index


Kiril Parushev
Re: AI to AE converting to shape layers - creating weird additional shapes
on Oct 14, 2015 at 1:06:18 pm

To everyone having the same issue:

I just updated my "Explode Shape Layers" script to the latest version and it has an option for exactly that. it removes the artboard artifact.

I hope this helps others who have the same issue.

The script:
http://aescripts.com/explode-shape-layers/

Although I find the script really helpful with its "explode" function aside from the "remove artboard artifact", if anyone has a free solution to the same problem, please share it.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]