ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

ProRes 422 timeline, ProRes 4444 renders

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Alan Langdon
ProRes 422 timeline, ProRes 4444 renders
on Oct 13, 2015 at 7:56:56 pm

I am editing a feature documentary in FCP 7.03, and the timeline is ProRes 422 29,97 fps 1080p.
When I render out animations in AE CS6, I keep these same settings except for the Codec, which I use ProRes 4444 with Alpha channel (straight). When I bring these into FCP, there is a visible pixelation or Moray-pattern, which makes it seem like the animation is not rendering out in the proper resolution or framerate or something... Any ideas? Is there a better codec to render out with an Alpha Channel?


Return to posts index

Dave LaRonde
Re: ProRes 422 timeline, ProRes 4444 renders
on Oct 13, 2015 at 10:25:30 pm

That's tough to say. You might have visual elements in the AE animation that coule cause a moire pattern. You might be inadvertantly rendering interlaced out of AE, and you're seeing that.

Do you have a screen shot of the problem for diagnosis?

Dave LaRonde
Promotion Producer
KGAN (CBS) & KFXA (Fox) Cedar Rapids, IA


Return to posts index

Alan Langdon
Re: ProRes 422 timeline, ProRes 4444 renders
on Oct 13, 2015 at 10:41:36 pm

Thanks for helping out, Dave.
I know it's a vague claim, and I would probably need to post a render to show what I mean. I've been using AE for 15 years now and there's always something you don't understand. I had this problem a while back and looked for any notes on how I solved but found nothing.

I did, though, just now try something that solved it while not making much sense. I think this is what I did to solve it.

First of all, upon scrutiny, I noticed that FCP 7 was importing the footage as Upper dominant, although the AE Comp and render settings are Progressive.

Then I did a test render, and before setting it to go, I entered the Quicktime settings in the Output Module and went all the way deep where you configure the Quicktime settings (Format Options / Codec Settings), where you always get the message to "adjust the settings in the dialog provided by the codec, then close it when finished). In there, I did nothing but just observe that the settings are correct: Gamma Correction: Automatic and NOT interlaced... Closed the dialog box and went back to set the Comp to render.
And horay! This time rendered out and Final Cut understood the Quicktime as Progressive, not Upper...
Go figure!? Any idea why this happens?
The down side is that it means every time I need t render something, I need to go deep into the codec settings and then close the box like I did above. Whenever I re-render the Comp, I can just Duplicate With FileName and this seems to keep the Quicktime as Progressive when re-rendering.



Return to posts index


Dave LaRonde
Re: ProRes 422 timeline, ProRes 4444 renders
on Oct 13, 2015 at 11:16:28 pm

I'm going to bet that your FCP edit timeline is NOT set to a field order of None... and your footage may be the same way, too.

I don't know why FCP is such a pain in the neck when it comes to progressive video, but it is. For some reason it sees 1080 video and automatically assumes it's upper field first.

And depending on the camera that shot the footage, it might have been! Some cameras scan an entire frame, but record two fields. It's called progressive segmented frame. It behaves just like progressive, but as you have witnessed, you have to double-check what FCP's doing to it.

What you were seeing in the bad renders was probably just a single field. No wonder why it looked so crummy!

Dave LaRonde
Promotion Producer
KGAN (CBS) & KFXA (Fox) Cedar Rapids, IA


Return to posts index

Alan Langdon
Re: ProRes 422 timeline, ProRes 4444 renders
on Oct 14, 2015 at 2:16:01 pm

Thanks for the insight, Dave.
But as it is, the footage and timeline are indeed Progressive... I always take a lot of care to work in a optimized timeline, with the same settings as the footage (in 99% of the cases, Progressive, or None as FCP puts it).
I guess what I found is a quirk between FCP7, CS6 and Quicktime, possibly with the participation of Mavericks, my OS. But the procedure I discovered (which in essence is nothing but opening some settings windows and changing nothing inside them) seems to work, so that's a good relief.
Let me know if anything else crosses your mind on this, and I'll do the same especially if I discover something new on this topic. For now, I will write down my solution so I don't forget it :)



Return to posts index

Dave LaRonde
Re: ProRes 422 timeline, ProRes 4444 renders
on Oct 14, 2015 at 4:18:34 pm

You're obviously importing your AE animations into FCP. Look at the imported footage in the FCP bin. Check its field order. It probably isn't set to None. It's a common problem in FCP.

Dave LaRonde
Promotion Producer
KGAN (CBS) & KFXA (Fox) Cedar Rapids, IA


Return to posts index


Alan Langdon
Re: ProRes 422 timeline, ProRes 4444 renders
on Oct 14, 2015 at 8:01:41 pm

Thanks again Dave for the input.
YEs, I always import AE renders (Quicktimes) into FCP. And there, within the browser Fielld column, it has been saying Upper, which has been my problem, but now with the solution I found it imports as None. Is there somewhere where I should configure BEFORE importing? I know this is something that FCP has with audio, the frame-rate being important to set (Sequence settings in Audio & Video Setup) BEFORE importing audio, or else it might drift... but is there a similar procedure for importing Quicktimes? I never thought there was, always just imported them as they were created in AE or whatnot.



Return to posts index

Daniel Waldron
Re: ProRes 422 timeline, ProRes 4444 renders
on Oct 15, 2015 at 3:54:28 pm

Just a quick heads up that you can save a custom preset in After Effects so you don't need to keep changing the codec settings every time you export.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]