ADOBE AFTER EFFECTS: Forum Expressions Tutorials Podcasts Creative Cloud

3D camera path

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Adam Pope3D camera path
by on May 17, 2014 at 6:44:14 pm


I'm wanting to create a motion path for a camera to follow a car in 3D space, just like this example at 19:51.

I've created a road with a simple photoshop layer and then in the top camera view drew out the path and pasted the mask shape to the position layer of a Null. But when I turn the null 3D the path no longer matches what I drew out. Does anyone know how to do this?



Return to posts index

Michael SzalapskiRe: 3D camera path
by on May 19, 2014 at 4:20:00 pm

It sounds like you're saying that you are pasting 3d path data to a 2d null, changing the null to 3d, and then the path doesn't seem correct.

If so, perhaps the null should be 3d before you paste the path.

If not, perhaps you should explain in a bit more detail what you are doing and the end goal you are trying to accomplish.

- The Great Szalam
(The 'Great' stands for 'Not So Great, in fact, Extremely Humble')

No trees were harmed in the creation of this message, but several thousand electrons were mildly inconvenienced.

Return to posts index

Adam PopeRe: 3D camera path
by on May 19, 2014 at 4:45:50 pm

Hey Michael,

Thanks for responding! So I have a car model that I'm using with Element 3D. I made an image of a road in photoshop and I want the car model to follow the path of the road. This is what I have been doing:

1. Turn the Road layer 3d and rotate 90 in X,Create a path for the road
2. Create a 3d null and parent it to the Road layer
3. Copy the mask path and paste it to the position of the 3d null.
4. Create the group Null with the Car model from Element 3D and parent that to the 3d null with the position keyframes.

Problems I'm having:

1. When I paste the motion path to the position of the 3d null, the path jumps over and does not line up.
2. When I parent the Car layer to the path it will follow it, but doesn't seem to orient along the path when I have it set to do so.

Any ideas how to fix this would be much appreciated!



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 All Rights Reserved