ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Mask cut off early problem

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Jerry Smith
Mask cut off early problem
on Sep 27, 2015 at 9:18:48 am

I have a precomp that is a simple solid. Then in the main comp, the precomp has a mask. Actually, it is made up of a few masks that are simply added together. If I rasterize (*) the layer, then everything is fine. But I actually need it unrasterized for the motion blur to kick in. That's where the problem begins. Once I unrasterize the layer,for some reason the masked layer gets cut off on the right. It is a largish mask that stretches about 1750 of 1920 pixels across. The layer was scaled down to about 80%

I have tried enlarging the preocomp solid and scaling it. And I have tried "panning behind" of the layer. But to no avail.

I suspect/hope that somebody here might know exactly what the problem is. I encountered it a few months ago but was able to jerryrig something quick but can't remember what I did. I also think that time the mask was a lot smaller so I was able to just tweak something. This time it is more obstinate.

Thoughts?

Thanks


Return to posts index

Kalle Kannisto
Re: Mask cut off early problem
on Sep 29, 2015 at 10:36:23 am

Don't precompose the layer. Add the masks directly on the solid.


Return to posts index

Jerry Smith
Re: Mask cut off early problem
on Sep 30, 2015 at 1:37:24 pm

I was kicking myself after reading your reply because that is actually the one thing I should have come up with myself. Unfortunately, it doesn't work. And it is actually even worse because both rasterized and unrasterized the mask gets cut off.


Return to posts index


Kalle Kannisto
Re: Mask cut off early problem
on Sep 30, 2015 at 2:17:49 pm

Did you make the solid layer larger than the comp? If the solid is the same size as the comp, it will obviously cut off if you move it even one pixel, so it has to be larger than the comp -- or, if in 3D, closer to the camera so as to extend over the edges.


Return to posts index

Jerry Smith
Re: Mask cut off early problem
on Oct 6, 2015 at 1:49:25 pm

How can I change the size of the solid layer? I tried scaling the solid in the precomp version up to 1000% to no avail. The mask itself is scaled to 88%.

UPDATE: OK, I see how I can probably get it to work. Thanks.


Return to posts index

Jerry Smith
Re: Mask cut off early problem
on Oct 7, 2015 at 3:25:12 pm

Actually, I can't get it to work. The layer has to be scaled down to 88% so that the mask is the right size. But once I do that, it gets cut off if non-rasterized. I tried creating a precomp that was twice as big. But then the mask comes out twice as big. Strange.


Return to posts index


Kalle Kannisto
Re: Mask cut off early problem
on Oct 7, 2015 at 5:38:09 pm

Better scale the mask to 88%, not the whole layer. Select all points of the mask and press ctrl+T for transform. The layer should be larger than the mask, otherwise it will get cut off at the edges of the layer no matter what.


Return to posts index

Jerry Smith
Re: Mask cut off early problem
on Oct 9, 2015 at 10:29:17 am

Hmm... Well, there are 7 masks added together. And all of them need to be scaled 88.35%. Is there a way to do that?


Return to posts index

Kalle Kannisto
Re: Mask cut off early problem
on Oct 17, 2015 at 3:59:00 pm

Yes, you can select all the masks in the layer stack (timeline) and use free transform (Ctrl+T) with shift to scale all at once. The info window shows you the scale percentage.


Return to posts index


Jerry Smith
Re: Mask cut off early problem
on Nov 6, 2015 at 5:44:59 pm

Thanks Kalle,

I really appreciate all the help. That did the trick.

Although I do wish there was some way to lock the horizontal and vertical and then scale it to an exact number. I was able to get it close enough doing x, then y. So now I got nice motion blur! YAY!


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]