ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Blend modes - what am I missing?

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
russell birkettBlend modes - what am I missing?
by on Oct 19, 2014 at 9:56:04 am

Hi all
I'm sure this is a simple thing I'm missing, but I can't figure it out. I have a solid white layer that I wish to make transparent and cast shadows onto. I have accepts shadows set to 'only' and I'm in the 3D renderer. I've tried recreating a similar document and it's working in that, so I'm stuck as to what I did differently. Is there someone in a document that blend modes can be disabled, that I'm missing?
Thanks in advance
Russ


Return to posts index

russell birkettRe: Blend modes - what am I missing?
by on Oct 19, 2014 at 11:07:45 am

OK, an update. I can take that solid from the precomp (where the blend mode doesn't work) and paste it into the main comp and the blend mode works. Does anybody have any ideas why it wont work in the precomp?


Return to posts index

John CuevasRe: Blend modes - what am I missing?
by on Oct 19, 2014 at 12:05:00 pm

Track mattes and blending modes are not supported using the Ray-traced 3D Renderer. I'm not exactly sure how you can precomp them, and have them work in a final comp if you are using the 3D Renderer.

Johnny Cuevas, Editor
Thinkck.com

"I have not failed 700 times. I have succeeded in proving that those 700 ways will not work. When I have eliminated the ways that will not work, I will find the way that will work."
---THOMAS EDISON on inventing the light bulb.


Return to posts index


russell birkettRe: Blend modes - what am I missing?
by on Oct 19, 2014 at 2:31:15 pm

Thanks for your reply John.
I'm using the classic rendered, in all precomps and final comp.


Return to posts index

John CuevasRe: Blend modes - what am I missing?
by on Oct 19, 2014 at 3:40:25 pm

Your explanation of the problem is a bit confusing. Are you trying to use blend/transfer modes or are you using a solid with 3D enabled and want it to receive shadows only.

As far as blend modes go, if you have one set in a precomp and want it to transfer to the final comp, you need to enable continuous rasterization of the precomp in your final composition. It's the icon that looks like a little sun in the switches column.

Johnny Cuevas, Editor
Thinkck.com

"I have not failed 700 times. I have succeeded in proving that those 700 ways will not work. When I have eliminated the ways that will not work, I will find the way that will work."
---THOMAS EDISON on inventing the light bulb.


Return to posts index

russell birkettRe: Blend modes - what am I missing?
by on Oct 19, 2014 at 6:28:01 pm

I'm trying both ways actually, hoping that one will work. Primarily, I have a solid layer that I've made 3D, onto which I am casting shadows only, exactly as you have said. If I have this layer in a precomp, I can get shadows to be cast on it fine, but I can also see the solid white layer even though I have switched it to receive shadows only. If I cut this layer and paste it into the main comp, then it all works as intended - it receives shadows only.
I realise that blend modes doesn't factor into this method, but even if I change blend modes, there is no discernible change.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]