ADOBE AFTER EFFECTS: Forum Expressions Tutorials Podcasts Creative Cloud

Camera parented to Null not moving

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Anna RoscoeCamera parented to Null not moving
by on Jan 15, 2014 at 10:43:59 am

Hey there, so I already posted this question a few days ago on another topic, but I figured maybe it wasn't seen because it's such an old thread.

Basically, here is my problem:
I've parented the camera to the null object and i'm keyframing the null to move it in 3D space. I see the numbers of the position moving, and the shape of the Null is moving as well, but the camera is just stuck in place.

I have made sure the null object is a 3D layer, that the comp is set to active camera, and the camera is parented to the null.

I was following a tutorial for motion graphics/transitions. I have two clips lined up on top of each other, wanting to pan across them. I moved one of them to the right in the 3D space while the other one stays where it is. Then I moved the Null object, so it pans across. The null object is moving, but the camera isn't.

I took a screenshot of my project, here.

I have no idea what I did wrong. Any ideas?
Thanks in advance!

Return to posts index

John CuevasRe: Camera parented to Null not moving
by on Jan 15, 2014 at 5:18:45 pm

I think your camera has the Point of Interest turned on, which is the point of using a Null. If you turn the view to the top view and press AA, you will see the point of interest and can move it around(just for future reference). What you need to do is select the camera, press "cntl+alt+o" and turn the Auto Orientation to "Off".

Johnny Cuevas, Editor

"I have not failed 700 times. I have succeeded in proving that those 700 ways will not work. When I have eliminated the ways that will not work, I will find the way that will work."
---THOMAS EDISON on inventing the light bulb.

Return to posts index

Chun Leong LeeRe: Camera parented to Null not moving
by on Oct 16, 2015 at 5:10:58 pm


am new to AE and have been trying out the camera parenting the null object. i met the same issue, unable to move my null object in the Active camera view.

i had tried: 1) parenting the camera to the null object 2) ensure null object is 3d 3)ensure point of interest is turned off 4) viewing in the active camera view. However i still can't get the zoom and pan. i noted that it is moving in the top view for the camera.

pls advise. thank you

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 All Rights Reserved