ADOBE AFTER EFFECTS: Forum Expressions Tutorials Podcasts Creative Cloud

Mask Shape Keyframes Not Working

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Martin BanksMask Shape Keyframes Not Working
by on May 3, 2013 at 12:20:23 am


I've used the Mask Path keyframing option before to animate lots of masks over different footage.....but that was a few years ago.

Today I want to animate a very simple mask over some footage but I'm having issues. Here are the steps I'm taking:

- I draw my mask like I used to using the pen tool.
- I place my play-head at the start of where I want to animate it and click the stopwatch on the Mask Path option.
I then move to the frame I want then end keyframe at and move the nodes/anchor points of the mask.

In the past this would have added a keyframe, and then when I scroll the playhead I would have been able to see the mask moving.

This time no keyframe is added and it alters the shape of the mask at the original entered keyframe.

I even tried maunally adding the second keyframe and then changing the shape, however this still didn't work at the mask does not animate.

If anyone could let me know where I'm going wrong it would be grately appreciated. I'm sure it was this simple before!

Many thanks,

Return to posts index

John CuevasRe: Mask Shape Keyframes Not Working
by on May 3, 2013 at 1:03:59 pm

You've 100% described the technique to animate a mask, nothing has changed. Go to the help menu and do a "check for updates", to make sure there isn't anything buggy...I had some mask problems in the first CS6 version.

If you are still having problems, you might want to delete your preferences by starting after effects and holding down "cntl+alt"shift" as it starts up, if you do this correctly you will get a pop-up asking if you want to delete your preferences, but I would only do this as a last resort.

Johnny Cuevas, Editor

"I have not failed 700 times. I have succeeded in proving that those 700 ways will not work. When I have eliminated the ways that will not work, I will find the way that will work."
---THOMAS EDISON on inventing the light bulb.

Return to posts index

Jaclyn CataldiRe: Mask Shape Keyframes Not Working
by on Aug 28, 2015 at 6:09:48 pm

I was having the same issue while camera mapping an image. I had a mask applied to an adjustment layer, and was trying to animate the mask path with no success. I found that keyframes were not being added because when I moved the mask around it was actually adjusting the position of the entire layer. Not sure if this is your exact situation, but try making sure the path option is highlighted before selecting the mask in the comp.

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 All Rights Reserved