ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

alt+p for keyframe position not working

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Evan Petersalt+p for keyframe position not working
by on Mar 12, 2013 at 3:01:54 pm

Hello guys,

Taking a course from Lynda in AE CS6. Everything's been going very well. Today I encountered my first discrepancy with the instructions.

I'm on chapter 4 lesson two of After Effects CS6 Essential Training, relating to keyframes.

The instructor has me select 3 layers, place my cursor to the appropriate time and then press alt+p to set a keyframe for all the layers. Well, nothing happens. I have done a little research and haven't found an answer yet. I am in the US on a US keyboard. As far as I can tell my alt key is working.

I came to you guys because you have NEVER let me down. This place rocks, thanks again. I hope you can help me figure this out.

Thank you


Return to posts index

John CuevasRe: alt+p for keyframe position not working
by on Mar 12, 2013 at 4:03:17 pm

Try shift+alt+P

Johnny Cuevas, Editor
Thinkck.com

"I have not failed 700 times. I have succeeded in proving that those 700 ways will not work. When I have eliminated the ways that will not work, I will find the way that will work."
---THOMAS EDISON on inventing the light bulb.


Return to posts index

Ashish GuptaRe: alt+p for keyframe position not working
by on Mar 12, 2013 at 4:05:33 pm

Evan,

It's shift+alt+p ...


Return to posts index


Paul RoperRe: alt+p for keyframe position not working
by on Mar 12, 2013 at 5:09:16 pm

Hmmm.....alt + p works for me to add position keyframes.
alt + s for scale keyframe, alt + r for rotation keyframe.

- Paul


Return to posts index

Evan PetersRe: alt+p for keyframe position not working
by on Mar 12, 2013 at 6:24:40 pm

Thank you guys, very much, for the fast replies.

I won't be at my computer until later tonight. I will post the results of shift+alt+p then. Also I will give you exact course name and chapter (I gave a basic description in first post, btw.)

Thanks again,

Evan


Return to posts index

Vishesh AroraRe: alt+p for keyframe position not working
by on Mar 12, 2013 at 8:30:21 pm

Evan

Even is the Documentation, It is what you have seen the tutorial. I have a tutorial of motion graphics from Lynda.com and the instructor used Alt + P though it was not the same in my case. As mentioned above by others, Shift key is missing in the combination. Don't know how it works for them.

From Adobe Documentation
Add or remove keyframe at current time

Alt+property shortcut

Option+property shortcut


Vishesh Arora
3D and Motion Graphics Artist
Films Rajendra

Blog:
http://digieffects.wordpress.com

2011 3D Demo Reel:








Return to posts index


Todd KoprivaRe: alt+p for keyframe position not working
by on Mar 12, 2013 at 8:47:51 pm

As others have said, it's Alt+Shift+P.

There appears to be a mistake in the documentation that says that it's just Alt+P.

---------------------------------------------------------------------------------------------------------
Todd Kopriva, Adobe Systems Incorporated
After Effects quality engineering
After Effects team blog
---------------------------------------------------------------------------------------------------------


Return to posts index

John CuevasRe: alt+p for keyframe position not working
by on Mar 13, 2013 at 12:50:45 am

Glad we could help.

Johnny Cuevas, Editor
Thinkck.com

"I have not failed 700 times. I have succeeded in proving that those 700 ways will not work. When I have eliminated the ways that will not work, I will find the way that will work."
---THOMAS EDISON on inventing the light bulb.


Return to posts index

Evan PetersRe: alt+p for keyframe position not working
by on Mar 13, 2013 at 2:09:33 am

Okay, I just tried it and yes, shift+alt+p does work for the intended purpose of setting the position keyframe.

The exact course from Lynda which gave the wrong advice (amazingly) was: "After Effects CS6 Essential Training" with Ian Robinson, Chapter 4 lesson 2. The file name for the tutorial is: 04_02_Keyframes

Thanks again, guys. You are absolutely the best support on the web that I know of.

Evan


Return to posts index


Evan PetersRe: alt+p for keyframe position not working
by on Mar 13, 2013 at 2:42:55 am

He also makes another error in there saying alt+p for opacity keyframe when in reality it is shift+alt+p.


Return to posts index

Paul RoperRe: alt+p for keyframe position not working
by on Mar 13, 2013 at 8:53:00 am

I checked out that course, and yes, he definitely does say alt+p, but it totally works on my machine (a Mac running AE CS6: 11.0.2.11 and MacOS 10.7.5). If I have no layers selected, and press alt+p, it sets a position keyframe for all layers. If I have one or more layers selected, it sets a position keyframe for those layers. Same with alt+r for rotation, alt+t for opacity and alt+s for scale. Holding down shift achieves exactly the same result.

Seems very odd that we're getting different results.

- Paul


Return to posts index

Paul RoperRe: alt+p for keyframe position not working
by on Mar 13, 2013 at 12:26:10 pm

...so if any of you guys select a layer and then press alt+p, nothing happens?


Return to posts index


Evan PetersRe: alt+p for keyframe position not working
by on Mar 13, 2013 at 1:14:41 pm

Sorry guys, I should have stated I'm on a PC.


Return to posts index

John CuevasRe: alt+p for keyframe position not working
by on Mar 13, 2013 at 2:29:47 pm

On a PC(CS6), nothing happens with shift+(transform property), shift+alt+(transform property) does set at keyframe at the CTI

Johnny Cuevas, Editor
Thinkck.com

"I have not failed 700 times. I have succeeded in proving that those 700 ways will not work. When I have eliminated the ways that will not work, I will find the way that will work."
---THOMAS EDISON on inventing the light bulb.


Return to posts index

Paul RoperRe: alt+p for keyframe position not working
by on Mar 13, 2013 at 5:25:39 pm

What about alt+p (or other property) on a PC?


Return to posts index


John CuevasRe: alt+p for keyframe position not working
by on Mar 13, 2013 at 6:06:23 pm

I think I've tried every combination on a PC and the other way to get it to work as it should is alt+shift+(T,R,P,A,S)

Johnny Cuevas, Editor
Thinkck.com

"I have not failed 700 times. I have succeeded in proving that those 700 ways will not work. When I have eliminated the ways that will not work, I will find the way that will work."
---THOMAS EDISON on inventing the light bulb.


Return to posts index

Willie FrazierRe: alt+p for keyframe position not working
by on Mar 13, 2013 at 6:23:58 pm

Confirmed here that alt+P (or any other transform modifier such a R, T, or S) does most definitely create a keyframe on the Mac. It appears from what I have seen here that the behavior is different on a PC, however, and this difference is missing in the documentation which would explain why it is absent in the lynda course.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]