ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Stopping Frame Interpolation

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Tom HamiltonStopping Frame Interpolation
by on Mar 4, 2013 at 1:54:41 pm

Hi there,

I've got a project where i'm putting text into live action. Everything is tracked and working fine, but i have to time remap the comp. When i do, the text doesn't stay in line with the footage. Now i'm pretty sure this is because after effects is interpolating between frames for the text, but doesn't have a frame to interpolate for the footage.

In an ideal world, i'd like to just switch of the interpolation of the text, to match the footage, rather than generating new frames for the footage to match the text.

Is there a way to do this?

Cheers

Tom


Return to posts index

Todd KoprivaRe: Stopping Frame Interpolation
by on Mar 4, 2013 at 8:36:33 pm

If you're seeing interpolation between frames, you must have frame blending turned on. You can turn it off.

---------------------------------------------------------------------------------------------------------
Todd Kopriva, Adobe Systems Incorporated
After Effects quality engineering
After Effects team blog
---------------------------------------------------------------------------------------------------------


Return to posts index

Tom HamiltonRe: Stopping Frame Interpolation
by on Mar 5, 2013 at 11:13:25 am

Perhaps interpolation is the wrong word. I'll try and explain it a bit better.

So i have a comp with footage, and text tracked in. Now if i take that comp and time remap it to 1.3x the speed, there will be inbetween frames that don't exist for the footage, but there will also be inbetween frames for the text. After effects can acheive the exact position that the text should be in based on the remap, but can't choose the correct frame for the footage, because it doesn't exist (without frame blending). The result is that the text is slipping vs the footage.

Now if we take the footage on its own and time remap to 1.3x, i don't mind that it's not interpolating the in between frames, it's not noticeable. It's worse if i use frame blending because of artefacting. So i'd prefer it if there was a way to tell after effects to use integer frames (1,2,3,4,5,6,7 etc) for the text, rather than using float numbers (frame 1.3,2.6,3.9,5.2 etc).

The only solution i've found so far is to prerender the comp, and then time remap the new footage. However, i'm going to need to do lots of versions of the same comp with different text, so this isn't really an option.

Does this make sense?

Thanks for you help,

Cheers

Tom


Return to posts index


Todd KoprivaRe: Stopping Frame Interpolation
by on Mar 5, 2013 at 9:48:43 pm

One way is to force a specific frame rate on an item with the Posterize Time effect. If you follow that link, there is another suggestion on that page regarding using different frame rates for nested compositions.

---------------------------------------------------------------------------------------------------------
Todd Kopriva, Adobe Systems Incorporated
After Effects quality engineering
After Effects team blog
---------------------------------------------------------------------------------------------------------


Return to posts index

Tom HamiltonRe: Stopping Frame Interpolation
by on Mar 5, 2013 at 9:59:57 pm

Hi Todd, i just did a quick test by using posterize time on an adjustment layer inside the comp, then time remapping, and it looks like its going to work!

I'll need to do a test on the real project tomorrow, but fingers crossed, this is the solution. Thanks a lot!


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]