ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Shatter showing only solid, not the custom map

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Nuno MarquesShatter showing only solid, not the custom map
by on May 31, 2012 at 9:17:30 am

Hi all.

Trying to create a extruded version of an image. Thought I'd use shatter. I create a new project, import my map (dark 001.psd) and create a new comp with this psd file. Now on top of that I throw a solid, comp sized.
Apply shatter to the solid. In the effects panel, under shatter -> view I change to rendered and under shatter -> shape I change pattern to custom and change the custom shatter map to dark 001.psd. At this point I expected to see my psd shine through, but all I see is the cutout shape of the object present in the psd, painted in the solid's quasi black color.

Everywhere I look I seem to be doing it right, but I just don't see the underlying image.

Ideas?

On Win7, running AE5, Core i7 32GB RAM and Nvidia's GeForce GTX 690.


Return to posts index

John CuevasRe: Shatter showing only solid, not the custom map
by on Jun 1, 2012 at 11:23:10 am

Are the forces(they cause the objects to shatter) intersecting with your object. If you turn the view to wireframe + forces it will look like a blue ball right in the middle of your screen. You can move this forward or backward, so it doesn't intersect and you should see your image. Keyframing the force is what causes objects to shatter.

If you determine it's not the force object, I could take a look at the project. Use the "Collect Files" command, zip your project and upload it here. I'll take a look at your workflow and see if I can figure out what's causing the problem.

Johnny Cuevas, Editor
Thinkck.com

"I have not failed 700 times. I have succeeded in proving that those 700 ways will not work. When I have eliminated the ways that will not work, I will find the way that will work."
---THOMAS EDISON on inventing the light bulb.


Return to posts index

Nuno MarquesRe: Shatter showing only solid, not the custom map
by on Jun 1, 2012 at 1:26:47 pm

I have played around with the force values, even the camera system. Still not having much luck. I am pretty sure it's something really obvious, but I am oblivious as to what it may be... Uploading file.

I am trying to apply the shatter extrusion effect to each face of the 3d cube, to make it seem like all 6 side are floating around a single pivot point.


Return to posts index


Nuno MarquesRe: Shatter showing only solid, not the custom map
by on Jun 1, 2012 at 1:29:05 pm

Sorry. I still haven't got the hang of how to post files to a reply. Here's where the files ended up:
http://f1.creativecow.net/4229/3d-cube


Return to posts index

John CuevasRe: Shatter showing only solid, not the custom map
by on Jun 1, 2012 at 3:55:55 pm

I think I get what you are trying to do(not 100% sure). If I understand correctly, what you need to do is in the shatter effect twirl down Textures and change the pulldown "Front Layer" to layer 8(Front.psd). That will give you an extruded layer.

I'm not exactly sure if you really want to mess with the rest of the cube than or not.

Johnny Cuevas, Editor
Thinkck.com

"I have not failed 700 times. I have succeeded in proving that those 700 ways will not work. When I have eliminated the ways that will not work, I will find the way that will work."
---THOMAS EDISON on inventing the light bulb.


Return to posts index

Nuno MarquesRe: Shatter showing only solid, not the custom map
by on Jun 2, 2012 at 3:28:13 pm

Yeah, I want to "extrude" all sides of the cube. I did what you said, but for some reason, now it won't conforme to the layer size. I get a comp sized extruded frame. It sits over the remaining sides. And try as I might, I can't rotate it using the set camera. I even changed to comp camera.



Return to posts index


John CuevasRe: Shatter showing only solid, not the custom map
by on Jun 4, 2012 at 2:39:02 pm

Sorry for the delay, don't have CS6 at home.

What you are trying to do is a pretty difficult task, combing shatter with PSD layers to create a cube. Shatter projects a 3d look from a 2d layer, it interacts with a 3d camera. But it's not a true 3d object, turn on it's 3d box and rotate it and the illusion of 3d disappears and you will see it's a flat 2d object.

Yeah, I want to "extrude" all sides of the cube. I did what you said, but for some reason, now it won't conforme to the layer size. I get a comp sized extruded frame. It sits over the remaining sides.


Shatter conforms to the layer it's applied, not the texture layer. You applied it to a solid that is comp size 1280x720, your psds(texture) are 760x760. When applied as a texture they are stretched to the solid size. So you would need to make your shatter layer 760x760 and also make your psds, 100% in scale, it won't match up otherwise.


And try as I might, I can't rotate it using the set camera. I even changed to comp camera.



It may be possible to line them up with shatter and work with a camera(I'm using the camera in your project and it still works), but I don't think you could extrude those 5 sides using shatter. As I said before, shatter doesn't truly create a 3d object.

A project like this would probably be better suited to Cinema 4d.

Johnny Cuevas, Editor
Thinkck.com

"I have not failed 700 times. I have succeeded in proving that those 700 ways will not work. When I have eliminated the ways that will not work, I will find the way that will work."
---THOMAS EDISON on inventing the light bulb.


Return to posts index

Nuno MarquesRe: Shatter showing only solid, not the custom map
by on Jun 4, 2012 at 3:33:46 pm

Hey, no worries about the delay. If anything I should be thanking you for even taking the time to respond.

Cinema4D, ei?! Seems like a nice excuse to get "the boss" to open up his purse strings :)


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]