ADOBE AFTER EFFECTS: Forum Expressions Tutorials Podcasts Creative Cloud

Mocha for AE CS4 corner pin tracking data problem.

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Andrea CossuMocha for AE CS4 corner pin tracking data problem.
by on Apr 22, 2012 at 12:48:55 am

Hello everyone, I'm new to Mocha and After Effects and, guess what, I have a problem.
I'm working on a project based on the famous idea behind the "Picture frame" effect of an old HP commercial (the one where people had their faces "printed" on blank frames).
As I could see after a quick search, the topic has been debated many times on this forum, but I could not find a tip to correct my mistakes.

So, I make a corner pin tracking on Mocha of the blank frame sliding off of my face, and it seems pretty smooth to me, since I resized and corrected X-Spline layers and Surface to fit and follow the frame as precisely as I could, frame-by-frame.
I check the "Perspective" option, and then export tracking data into a .txt file for After Effects CS4.
Then, I open up my project on AE, duplicate the layer I want to apply the tracking to, make a frozen frame at the start, and make a mask surrounding the shape of the frame I'm holding in front of my face.

Finally, using a script called "MochaImport.jsx", I import the data from the .txt file selecting "Red giant warp corner pin - keep frame".

The tracking motion is basically now set, and when I play I can see the data has been imported like 90% well, for the still image follows the blank frame closely and with some sort of perspective.
But, there are several frames where is obvious that the tracking data goes on his way, since you can clearly see blank spaces surrounding the still image, it rotates or scales differently, not like it was edited on Mocha, or it even crosses the frame's borders sometimes.

I tried re-editing and re-exporting from Mocha (even thought there was barely anything to correct, since the "mistakes" only appear on After Effects, on Mocha it still looked smooth and all), but nothing has changed.
If I try to move the masked layer directly on AE to fit one particular frame, it messes all the other ones.

It seems that data has not been imported 100% correctly, or else I don't really know what happened, if this is normal or not, whatever.

What should I do? Sorry for the long post, I tried to be as clear as possible to help you help me out!

Thanks in advance.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 All Rights Reserved