ADOBE AFTER EFFECTS: Forum Expressions Tutorials Podcasts Creative Cloud

Artifacts with Custom Shatter Map

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Shana NunezArtifacts with Custom Shatter Map
by on Mar 13, 2012 at 10:30:04 pm

Hi there -

I'm pretty new to After Effects and I've been working on a project where I'm taking a logo (designed in dots) and using the shatter effect to bring it together. I'm using a custom shatter map and setting the shatter map image back to the logo image itself. This gives me the perfect shatter effect where my dots separate out just as I was wanting. However, I'm getting some bad artifacts as well as my dots becoming pixelated around the edges themselves.

I've watched two tutorials on this site on using the custom shatter map. I've tried a couple of different things like duplicating my logo and recoloring it, making it black and white, using colorama on it, etc. but all give me worse results.

What am I missing here? Thank you so much in advance for any tips you can give!

Here's the render of the logo comp (I'm reversing this for my effect).

And here's a zoomed in image of my "confetti" artifacts I'm getting.


Return to posts index

Dave LaRondeRe: Artifacts with Custom Shatter Map
by on Mar 14, 2012 at 10:01:15 pm

Could this be a resolution issue? What's the resolution of your shatter layer?

Could this be an aliasing issue? What's the file format of your logo made out of dots, and what's its resolution?

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA

Return to posts index

John CuevasRe: Artifacts with Custom Shatter Map
by on Mar 15, 2012 at 1:12:57 am

I think your smoothness problem is because shatter can't anti-alias.

As for the artifacts, I started messing with shatter and I've been getting the same issue just using a 4 colors in my custom map. I threw a threshold effect on an adjustment layer and it fixed the problem, but I don't know if that's practical for you. Making my custom map greyscale actually made the problem worse. Not sure what is causing it, I haven't had this problem before, but it's been awhile since I've used shatter, so perhaps a 64 bit issue, I don't know.

Johnny Cuevas, Editor

"I have not failed 700 times. I have succeeded in proving that those 700 ways will not work. When I have eliminated the ways that will not work, I will find the way that will work."
---THOMAS EDISON on inventing the light bulb.

Return to posts index

Ryan HillRe: Artifacts with Custom Shatter Map
by on Mar 16, 2012 at 3:44:54 pm

Yes, with anti-aliasing, there are some semi-transparent pixels around the edge of each dot, and shatter is treating those as a separate colour.

I would suggest:
1) Version of the logo with transparent background
2) Version of the logo with the size of the dots slightly increased (But not so much that they touch) and no anti-aliasing

Use version 2 as the shatter map.

Return to posts index

Shana NunezRe: Artifacts with Custom Shatter Map
by on Mar 22, 2012 at 9:14:11 pm

Thank you everyone for the feedback.

The logo is an illustrator file with a transparent background.

I tried many things from recoloring the shatter map to making it all black with a transparent background.

Ultimately, I've discovered that if I make all the dots black in illustrator and apply the shatter map to that, then apply my colored logo as the texture layer, I get rid of the artifacts and have the logo in the color I want.

Whew... that took a bit of futzing.

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 All Rights Reserved