ADOBE AFTER EFFECTS: Forum Expressions Tutorials Podcasts Creative Cloud

After effects masking not working.

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Nathan SmithAfter effects masking not working.
by on Dec 3, 2011 at 5:50:46 am


I would like to know what I'm doing wrong. I am a beginner who is trying to learn about after effects. I want to mask something, but it only works inside the "layer" and not the composition.

Here are two screen shots:

in the layer:

in the composition:

Is there a setting that is not turned on or something? What am i doing wrong. Also I'm trying to make a directional fade. After effects only offers a opacity setting to fade the entire screen where I want to fade for example starting on the left and ending on the right. I was planning on creating a mask with a lot of feathering to reveal the layer underneath, but I'm open to better suggestions.



Return to posts index

Angie TaylorRe: After effects masking not working. #AfterEffects
by on Dec 4, 2011 at 9:20:31 am

Hi Nathan,

It's hard to tell as I can't see the entire Timeline but it's most likely to do with the Mask Modes you are using. Try setting them both to Add first to make sure you can get them working (also, double-check there isn't another copy of the layer beneath this one I can't see in your screenshot!)

If they work in Add mode then you may want to experiment using Intersect or Difference mode to get the effect you want.

By the way, if you just want a soft wipe then you may want to try some of the free transition affects as an alternative. For Example the basic Linear Wipe transition will do pretty much what you want and is much easier to set up.

Hope this helps!



Angie Taylor animation & illustration for television, film, web and devices
Twitter: theangietaylor
Linkedin: theangietaylor

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 All Rights Reserved