ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Rendering proper progressive output with DV codec

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Roger MatthewsRendering proper progressive output with DV codec
by on Jan 20, 2010 at 8:11:46 pm

Hi, I'm running AE CS4 on Windows XP, and have to admit I am baffled on a very simple problem.

All I am trying to do is render progressive (no field order) DV footage from AE. However, no matter what I do (specify the field order as No Field Order in the render queue, go to Interpret Footage -> Main and make sure Specify Fields is Off) my rendered footage is showing up as interlaced in Sony Vegas 8 Pro when imported. The original video shows up correctly, as progressive.

The source footage in AE is all progressive, so there is no reason (as far as I know) for AE to assume the output should be interlaced. I've read that it might treat all DV renders as interlaced, but then why give the option to output progressive?

Now I could render uncompressed and then convert to the proper format later, but I am dealing with hours of rendered footage on an old machine, and would really like to avoid this if possible.

I have tried reading whatever I can find online, and finally come here, knowing how helpful this place has been for me. So I hope this question isn't TOO simple/obvious, and someone can give me any answer. Thanks a lot!

Roger


Return to posts index

Kevin CampRe: Rendering proper progressive output with DV codec
by on Jan 20, 2010 at 8:44:44 pm

by default, when dv footage is imported into ae, ae will probably assume that it is interlaced.

by choosing file>interpret footage>main and setting 'separate fields' option to off, you will tell ae not to deinterlace the footage (which it sounds like you have done already).

when you render (composition>add to render queue), by default ae should render as progressive. but you can check the render settings to make sure that 'field render' is set to off (again it sounds like you have done that too).

however, what type of dv is vegas looking for natively...? from ae's render queue you are most likely rendering and .mov with dv compression. does vegas take work with .mov natively, or is vegas converting/transcoding it to another container...? maybe .mxf or .dv? if that is happening then it maybe it's vegas that is interlacing the footage.

can you open the rendered dv file back in after effects or quicktime? double check that there is interlacing before the file is brought into vegas.

another option: use file>export>dv stream to create the dv file. set those settings to progressive and see how that imports into vegas. that file will be a .dv file and may work better with vegas (i don't know, i've never used vegas, i'm just trying to think of other options).

Kevin Camp
Senior Designer
KCPQ, KMYQ & KRCW


Return to posts index

Roger MatthewsRe: Rendering proper progressive output with DV codec
by on Jan 20, 2010 at 10:29:54 pm

Hi Kevin, thanks for the quick and thoughtful reply.

Sorry, I should have mentioned that I'm rendering using the .avi container, which is what Vegas accepts natively (and the format the rest of the footage for the project is in).

I also forgot to mention that when importing the RENDERED footage (created by After Effects) back into AE, it is still interpreted as interlaced.

I'm now trying that file->export->dv stream option, but AE warns me that I should use the render queue instead, so we'll see what happens. Not sure if Vegas accepts .dv natively, but I guess we'll find out.

However, my money is on something going on in After Effects that I'm just missing. I'll post if I can come up with anything else. Thanks again for responding so fast.



Return to posts index


Dave LaRondeRe: Rendering proper progressive output with DV codec
by on Jan 20, 2010 at 10:40:25 pm

[Roger Matthews] "I also forgot to mention that when importing the RENDERED footage (created by After Effects) back into AE, it is still interpreted as interlaced. "

That's because it IS interlaced. It has to be: the technical requirement for standard-definition NTSC video calls for 29.97 interlaced frames/sec. In order to maintain the standard, everything is recorded as two fields... even when you render whole frames.

All SD progressive-scan cameras record two fields, and 1080 30p cameras do, too: they give it a fancy name, Progressive Segmented Frame, better known as psf. The camera captures an entire frame at the same instant in time -- the Progressive part -- which is then recorded as two fields -- the Segmented Frame part. AE does it too when it renders to SD and 1080 HD.

So, yeah: your DV footage is interlaced.

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

Roger MatthewsRe: Rendering proper progressive output with DV codec
by on Jan 21, 2010 at 2:45:14 am

Dave,

I see, that's interesting about the proper definitions of certain words. Definitions in language can get mangled through popular use, huh?

That aside, when I import the new renders into AE, AE reads out specifically "Separating Lower" (Lower Field interlaced). The original clips are not marked as 'Separating Lower' (since the project was shot in progressive 'interlaced).

I also tried rendering in .dv format, but I still got Lower Field interlaced footage as a result. AE confirms the footage as Lower Field interlaced. So AE is definitely converting the footage into Lower Fields interlaced despite me disabling fields (or enabling psf) both inside the 'Interpret Footage' menu and in the Render Queue.

Really stumped here. What else can I do within AE to make sure the footage is rendered properly?

EDIT - forgot to mention, when I chose Export to DV to make the .dv file, I specifically was given the option between Interlaced or Progressive (or 'psf') and chose Progressive in a very simple menu. What gives?



Return to posts index

Dave LaRondeRe: Rendering proper progressive output with DV codec
by on Jan 21, 2010 at 3:44:53 pm

Bottom line: once you get the footage into your NLE, it doesn't matter. Since it was SHOT progressive interlaced, properly interpreted as lower field first, rendered without fields -- thereby -- telling AE to render as progressive fields -- and then imported into the NLE, the footage is fine.

Don't trust computer monitors for judging video, only video monitors. Are you losing vertical resolution in the picture when you look at it on a video monitor? No? Life is good. Yes? You need to fiddle with the fields in your NLE. Since every one has a different way of doing it, you'll have to consult the instructions for yours.

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index


Roger MatthewsRe: Rendering proper progressive output with DV codec
by on Jan 21, 2010 at 5:18:31 pm

Dave,

Well, exactly. No matter what you call it, the rendered footage is still not in the same format as the original footage, so my NLE has to either convert the footage in realtime (my computer is not fast) or re-render all of the footage to match (ridiculously inefficient).

What I am doing is rendering all of the raw footage from a B camera for a wedding to have it re-inserted into a larger multicamera project. It's just simply more efficient to have the new footage match the existing footage from the A camera, so Vegas doesn't convert the footage in realtime, on my admittedly slow machine.

If I was making a final render I wouldn't care, but in this case I'm using AE just because it has vastly superior color correction plugins available versus Vegas, and is needed. And most importantly, I want to have an efficient workflow for future projects that doesn't force conversion AFTER a render.

And while I could just pre-render the timeline, I am tweaking multi camera edits spanning about two hours, so that would be a major pain. It's all about efficiency here.


Return to posts index

Dave LaRondeRe: Rendering proper progressive output with DV codec
by on Jan 21, 2010 at 5:24:42 pm

I'd ask about this on the COW's Vegas forum.

Most of the folks around here use FCP, Avid or Premiere for editing. Every editing application has its quirks, Vegas is no different, but for must of us, Vegas is Terra Incognita. But SOME Vegas editor has no doubt done what you did, and can answer more definitively.




Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

Roger MatthewsRe: Rendering proper progressive output with DV codec
by on Jan 21, 2010 at 5:42:53 pm

Dave,

Thanks, good idea. As much as I like Vegas, I am getting sick of its lack of plugin support/public exposure, haha. Hence me branching out into AE, and probably new NLES as well soon.

Thanks for the quick replies.

Roger



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]