ADOBE AFTER EFFECTS: Forum Expressions Tutorials Podcasts Creative Cloud

RAM? Multiprocessing? I'm tired of Mac spinning wheel!

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Michael MehlhornRAM? Multiprocessing? I'm tired of Mac spinning wheel!
by on Aug 14, 2009 at 5:12:30 pm

So after doing some research on the site/forums I am still unsure and unable to figure out what to do so I am writing a post with attempts to fix my current issue. I am using After Effects CS3 on a Mac Pro Dual Core Intel Xeon (2 x 2.66 GHz) with 10GB 667 MHz DDR2 FB-DIMM running OS X 10.5.7.

In using After effects after adding some minor auto trace and stroke effects I somehow managed to make AE run really slow. I am not talking about waiting forever to render, but just waiting in general. For example to jump to another spot on the timeline when I slide the bar it takes at least 20 seconds of the spinning rainbow pinwheel before it finally shifts. Looking at my memory and CPU usage via Activity Monitors, I think I'm using much of the power I have in the machine. dont

The effects I'm doing aren't even really that graphics intense, and changing the resolution to 1/3 or 1/4 does not change the amount of time it wastes thinking. I don't think my settings are correct and I am pretty sure my AE is not using much of the 10 GB of RAM.

What can I do to make AE run smoothly again!


Return to posts index

Kevin CampRe: RAM? Multiprocessing? I'm tired of Mac spinning wheel!
by on Aug 14, 2009 at 7:29:51 pm

ae can have problems with certain media types. hdv, mpeg-2, h.264 and compressed audio files like mp3 can cause issues with how ae behaves. if you are using any of those in your project, then you should convert them to other media types. some good video codecs would be lossless animation, quicktime photo-jpeg or pro res. for audio i would only use wav or aiff.

if those formats aren't the problem, then i'd start looking at the preference settings...

quit ae and pull the ae pref file (called 'adobe after effects 8.0 prefs') to the desktop. it in users/username/library/preferences/adobe/after effects/8.0. then restart ae and test the project that you are having problems with. ae will restart with the original default preferences.

if it helped, then you can trash the file that you moved to the desktop. you may also want to change a few settigns from the default prefs. i would enable multiprocessing (you have plenty of ram for that). and, since your system is older, i would probably disable opengl for previews in the previews pref.

you can enable disk caching in the memory and cache settings, but do so only if you have your media stored on a separate drive than the boot drive and that drive is on a separate drive bus (not the internal drive bus)... basically, enable the disk cache option only if you have an external media drive and set the cache to be on the internal boot drive. otherwise your better off with disk caching off. i wouldn't tweak any other memory settings.

if moving the single preference file out didn't help, move the whole folder named '8.0' to the desktop and run ae.

if that doesn't help, then respond back.

Kevin Camp
Senior Designer

Return to posts index

Adam SimpsonRe: RAM? Multiprocessing? I'm tired of Mac spinning wheel!
by on Sep 13, 2012 at 9:28:41 am

Hi Kevin, I know this was a few years ago but wanted to mention that I followed your advice with AE CS5 after it was freezing on render out, and moved: Adobe After Effects 10.0 MC Prefs, and Adobe After Effects 10.0-x64 Prefs out of there.

It fixed the problem

Thanks Heaps

Adam Simpson

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 All Rights Reserved