ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Vertical lines with track matte?

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Alan Saul
Vertical lines with track matte?
on Apr 27, 2008 at 12:27:57 pm

Hello guys! My first post here so be nice! So for the last month or two I've been animating and rendering out a short movie, but now I've come into problems with the compositing stage!

I have two jpeg sequences, both clean crisp no lines or any artifacts which is why I have found the next bit so suprising! I am using one of the jpegs (black and white crisp solid colours, no greys) as a matte for the second (colour pass), Alpha matte doesnt seem to work (which is presumibly because the mask isn't actually the alpha channel to the other) and when I use Luma matte, come out with vertical lines as in the picture.

Does anyone have any ideas what might be causing this? I cant figure it out for toffee! For one of the scenes I manage to wangle a way around it with a combination of several track mattes and very odd layer organising but I just cant figure out why they are appearing in the first place!

http://img91.imageshack.us/img91/4874/pigeonmovie0001610gv7.jpg

Thanks ever so much,

Alan


Return to posts index

Alan Saul
Re: Vertical lines with track matte?
on Apr 28, 2008 at 12:01:49 pm

No one any idea why this is happening? I would just like to add that it appears to be applied after everything else, as in when I begin previewing it, for a split second the correct version is shown in the preview, then the lines are added on top which makes me believe it is something to do with an effect or something?

I could screenprint a image of my layers pallette if I haven't given enough to go on?



Return to posts index

Felipe Pellisser Albergard
Re: Vertical lines with track matte?
on Feb 19, 2009 at 3:21:17 pm

Hello Guys!

I had this problem for a long time, and one day I decide finish with this issue.
What you have to do, is work with "open GL - always on". In the Composition Screen, find the icon of Fast Previews and choose: ("open GL - always on"). After this, a icon of Open GL will appear in the top of the Composition screen".
But this only help you during the edition process.
To render the work without the lines, you have to enable the Open GL Renderer. How do this?
Open the Render Settings (Render Queue) and above "Disk Cache", find the option: "Use Open GL Renderer".


More about open GL:

OpenGL is a set of standards for high-performance processing of 2D and 3D graphics for a wide variety of applications. For After Effects users, OpenGL provides fast, high-quality rendering for previews and final output by moving rendering from the CPU to the OpenGL hardware (GPU).

To use OpenGL in After Effects, you'll need an OpenGL card that supports OpenGL 2.0 and has Shader support and support for NPOT (Non Power of Two) textures.


*I'm try to improve my english, sorry for any mistakes.




Return to posts index


jip
Re: Vertical lines with track matte?
by
on Apr 14, 2010 at 10:16:46 pm

I've been running into this too working at 32bit in a serious manner. The OpenGL solution does get rid of the lines, but makes me nervous about the stability issues with AE. Usually I turn OpenGL off immediately because it seems to cause crazy crashing.

Anyway, another solution is to just precomp the track matte and the layer being tracked together. Seems to somehow solve the issue as well and this allows you to keep OpenGL off. I can only surmise that this is some buggy interaction of the video card and AE.



Return to posts index

Alex Brown
This worked for me...
on Jun 15, 2011 at 12:12:58 am

Okay, this thread is officially ancient and I'm sure you've figured something out by now, but I ran into this problem today as well. I was using a very simple track matte to create a transition between two layers and found the project was riddled with small vertical lines, almost like a card wipe transition was applied 1% or so.

I struggled with a lot of possible fixes and nothing worked until I turned the layers 3d. Boom, lines disappeared and it rendered fine. I didn't even have a camera in the scene, but it worked.


Return to posts index

Joe Leih
Re: This worked for me...
on Oct 9, 2012 at 11:21:43 pm

Adding to the thread a year later than the last post... but I too wrestled with this. Pre-comping the layers didn't work, Turning on OpenGL didn't work, 3d-ing the layers didn't work, etc. Finally what worked was changing the color bit depth. If I turned on 8bit or 32bit float, the lines disappeared. If I was in 16bit, they remained. Have no idea why.


Return to posts index


Ryan Kavanagh
Re: Vertical lines with track matte?
on Oct 2, 2014 at 8:38:22 pm

I ran into a similar problem to this with jpegs in after effects, and it turned out to be the shadow diffusion in the "light options". I pulled the shadow diffusion down from a few hundred to less than five and that did the trick. Hope this helps anyone else having this issue.



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2020 CreativeCOW.net All Rights Reserved
[TOP]