ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Element 3d and particular z depth problems

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Patrik Windahl
Element 3d and particular z depth problems
on May 29, 2016 at 2:54:48 pm

Hi.
I'm struggling to combine the z depth render from my element 3d plugin with particular. This image shows how the z depth render looks with default settings. It looks nowhere close to how the tutorials and documentations i have found.


After tweaking the settings i manage to get a result that matches the documentations i have read, but it requires the z depth start to be higher than the end, which also contradicts what i've read which makes me a bit confused.

And finally, no matter the settings i cant get particular to blend right with my z depth pass.


Any help would be greatly appreciated.


Return to posts index

Kalle Kannisto
Re: Element 3d and particular z depth problems
on May 29, 2016 at 5:37:41 pm

Yup, there are some complications to the method.

As for the Element Z-depth pass, you can invert the output for Particular. You get a cleaner result if you enable Preserve Alpha in the Z-Depth Output options.

Then you'll need to precompose the Z-depth layer. To do that successfully, I suggest using the Video Copilot 3D Precompose script so that you get a linked camera inside the precomp that follows the main comp camera.

Then you have to find the right settings for the particular Z at Black and Z at White, which you may need to further keyframe if you're going to be moving around.


Return to posts index

Patrik Windahl
Re: Element 3d and particular z depth problems
on May 29, 2016 at 11:44:23 pm

Thank you, i will try this.


Return to posts index


Patrik Windahl
Re: Element 3d and particular z depth problems
on May 31, 2016 at 9:45:19 am

Thank you so much! It worked great :) I cant believe the solution was so simple!


Return to posts index

Tony Lengyel
Re: Element 3d and particular z depth problems
on May 31, 2016 at 7:04:59 pm

This helped me too. I am new here and have always found this forum for the most insightful answers. So much I joined today and browsing through the forums and found this helpful post. Thanks so much and look forward to more helpful people as yourself.

Have great week.


Return to posts index

Philip Barbour
Re: Element 3d and particular z depth problems
on Oct 20, 2016 at 9:52:27 pm

Is anyone aware of any step by step or video tutorials that would help me do this with clouds or smoke? I tried this tutorial:



But it doesn't match up with what I'm trying to do. I'm just trying to get an Element 3D logo that I have to interact with Particular smoke/clouds in 3D space. This is clearly an advanced process. I'm totally good with Element, and mostly good with Particular. But Z Depth is seems very complicated.


Return to posts index


Michael Szalapski
Re: Element 3d and particular z depth problems
on Oct 21, 2016 at 4:37:39 pm

You have to precomp your Element layer with the Z-depth buffer/pass/whatever E3D calls it and move all of the attributes into that precomp. (And you'll need to have the camera in there too. This is where the copy with property links menu option is really handy - this way you can make changes in your main comp camera and have it happen in the precomp too.)

- The Great Szalam
(The 'Great' stands for 'Not So Great, in fact, Extremely Humble')

No trees were harmed in the creation of this message, but several thousand electrons were mildly inconvenienced.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]