ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Compositing shadows onto background plate with C4D multi pass causes edge issues

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Ryan ConstantinoCompositing shadows onto background plate with C4D multi pass causes edge issues
by on May 21, 2016 at 2:24:46 am

I'm rendering out multi pass layers of an animation where I have a blend channel, a shadow channel, and a motion vector channel. When I apply RSMB vectors to the layers, it blurs the edges separately, leaving weird edges. This is solved by pre-comping the blend and the shadow together, and then adding RSMB, but defeats the purpose because you can no longer see the video in the background (the shadows need to "multiply" onto the video footage). Here are screen caps which might explain better:

http://imgur.com/a/T4RTz

Is there any way to get around this?


Return to posts index

Ryan ConstantinoRe: Compositing shadows onto background plate with C4D multi pass causes edge issues
by on May 25, 2016 at 7:23:33 am

update: I figured it out for those searching. When using RSMB vectors on cinema4d multi-pass renders you have to Precomp the blend, shadow, ambient occlusion and whatever else together using the multiply modes inside the precomp where necessary, then take the object buffer and place on top of everything inside the precomp using it as stencil luma. Go to you main comp, add RSMB, then add the shadows and AO underneath the blend channel and use multiply mode to get the shadows and stuff onto the bg footage.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]