ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Transfer Position Problem

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Marc NiborTransfer Position Problem
by on Feb 15, 2016 at 3:02:05 pm
Last Edited By Marc Nibor on Feb 15, 2016 at 4:02:56 pm

I have a bunch of strokes which I made by rightclick > "create shapes from Vector layers" on an AI file 1920/1080.

When I then copy the "path" from one of these strokes onto a "write on" effect on a different layer (also 1920/1080), the path is transferred but it is offset and all my attempts to fix it (except moving it by hand) failed.

Is someone familiar with this problem and knows how to deal with it?

EDIT: Here's an important detail.
The offset looks like if the origin in the source layer is in the top left and in the destination layer in the center.
So for example if the stroke that I copy in originally in the center of the image it will be pasted to the lower right corner in the destination. I tried already to move the anchor point of the destination layer from center to 0,0. But it doesn't seem to make any difference.

EDIT2:
is there maybe any way to offset ALL keyframes (possibly with an expression?) in the "brush Position" Value? Brush Position is the value where I pasted the the path to.


Return to posts index

Cassius MarquesRe: Transfer Position Problem
by on Feb 15, 2016 at 4:33:06 pm

paste the position to a null, select all keyframes and adjust it, you can link it to another null to make any scalling/move easier. Unlink it after you're done then copy paste again to the effect.

Cassius Marques
http://www.zapfilmes.com


Return to posts index

Marc NiborRe: Transfer Position Problem
by on Feb 15, 2016 at 4:52:26 pm

Thank you for the reply Cassius.

The suggested solutions does not fix the problem thought.
I can right now already select all keyframes in the Brush Position parameter of the Write ON effect and move them with value slider.
So there is no need to create a null and do the workaround.

The problem is that I have about 60 of those shapes and I was hoping I could find away around fixing it all by hand ; )

I think the problem might have something to do with the origin coordinates inside of the AI file.



Return to posts index


Cassius MarquesRe: Transfer Position Problem
by on Feb 15, 2016 at 7:48:32 pm

is your .ai canvas the same size as your AE composition? Is your solid with the write on effect the same composition size? Are you importing your .ai layer while keeping layer dimensions or not?

I believe one of these settings combinations can solve the problem.

when everything is the same size (pixel wise) you can just copy paste the path from illustrator to AE. No need to import. Things will match.

Cassius Marques
http://www.zapfilmes.com


Return to posts index

Marc NiborRe: Transfer Position Problem
by on Feb 15, 2016 at 8:55:09 pm

Thank you Cassius,
the answer to all your questions is yes. exept - importing while keeping layer dimensions.... I don't see this option. I know it from importing PSD files but it didn't come up while importing the AI.

The attempt to import directly from Illustrator sounds good. I tried it several times just now. But when I paste the path in AE it places is not at it's original position. Instead it places it around the center of the canvas.

In case I can't find a way to fix this I will go the hard way and start doing it by hand ; )

Thanks you so much for your help!



Return to posts index

Cassius MarquesRe: Transfer Position Problem
by on Feb 16, 2016 at 1:41:36 pm

yeap, unfortunatly you are correct. I does come in displaced. Thats an odd behaviour indeed, one I thought didn't happen.

You can either reposition by hand (each) or create a boundry mask the same size of your comp. I believe the second method being easier since you can bring all your paths in once then just do the copy pasting.

Cassius Marques
http://www.zapfilmes.com


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]