ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Using time remapping to loop just doesn't work

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Kevin PatnodeUsing time remapping to loop just doesn't work
by on Jan 17, 2016 at 11:52:16 am

Hi, I've been trying to do the whole time remap, add expression and setting the property to loop, but it just doesn't work for me. I set everything up and have the two keyframes from start to finish, but when I drag the animation nothing happens. I click play in the preview and the animation doesn't loop and stays still after the original animation ends. What am I doing wrong?


Return to posts index

Chris EvansRe: Using time remapping to loop just doesn't work
by on Jan 18, 2016 at 5:19:09 pm

What expression are you using?

I would just copy the keyframes again and again for the duration, no expression needed. Though I have to admit I rarely use expressions and if I were more familiar with them, I might know of an easy way to achieve this with expressions.


Return to posts index

Cassius MarquesRe: Using time remapping to loop just doesn't work
by on Jan 18, 2016 at 7:13:52 pm

the simplest expression for a loop would be

time%"x"

"x" being the loop duration, in seconds. So a 2 second loop would be "time%2". This, applied to a time remmap property.

Cassius Marques
http://www.zapfilmes.com


Return to posts index


Kevin PatnodeRe: Using time remapping to loop just doesn't work
by on Jan 19, 2016 at 1:40:20 pm

I'm using the loopOut(type = "cycle", numKeyframes = 0) property. Also I tried the time%"x" thing as well and that didn't work either. I've found out that it only works if I precompose the animation and check off "Move all attributes into a new composition". Doesn't work if I check off "Leave all attributes in "x"'. The problem is, is that the animation itself has a bunch of separate body parts in it that are separately animated. So if I precompose some of the parts that I want to loop, then the other parts will no longer be parented to the ones that are precomposed and no longer move along with it.


Return to posts index

Cassius MarquesRe: Using time remapping to loop just doesn't work
by on Jan 19, 2016 at 7:06:36 pm

What you described is the expected behaviour. You should reconsider your workflow.

[Kevin Patnode] "So if I precompose some of the parts that I want to loop, then the other parts will no longer be parented to the ones that are precomposed and no longer move along with it."

If they are parented in the first place and you wanted them to loop you should precompose them as well. If you don't want them to loop why would you expect it should keep moving with what you just precomposed and looped?

What I'm trying to explain is that you're approaching things in reverse. If you can be more specif at what you're struggling with I can try to go about some way you can solve it.

Cassius Marques
http://www.zapfilmes.com


Return to posts index

Cassius MarquesRe: Using time remapping to loop just doesn't work
by on Jan 19, 2016 at 7:09:11 pm
Last Edited By Cassius Marques on Jan 19, 2016 at 7:11:52 pm

On a side note: What/Which part of the loopOut expression didn't work?


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]